[artix-general] X11 libinput seems to be the trouble

Ruben Safir ruben at mrbrklyn.com
Wed Jun 27 22:20:06 EEST 2018


It seems that the x program related to a library libinput.10

I stripped the system down in a cascade command with pacman removing
xorg and tried to reinstall and even with xdm started on the command
line I am getting no keyboard or mouse response... it just acts like it
is bricked (althouh networking and ssh is up).

I'm attaching the log.  I have no clue what to do further.

stripping it down and rebuilding it is not working.  There was a gcc
update.  Maybe that is triggering the problem.

-- 
So many immigrant groups have swept through our town
that Brooklyn, like Atlantis, reaches mythological
proportions in the mind of the world - RI Safir 1998
http://www.mrbrklyn.com 

DRM is THEFT - We are the STAKEHOLDERS - RI Safir 2002
http://www.nylxs.com - Leadership Development in Free Software
http://www2.mrbrklyn.com/resources - Unpublished Archive 
http://www.coinhangout.com - coins!
http://www.brooklyn-living.com 

Being so tracked is for FARM ANIMALS and and extermination camps, 
but incompatible with living as a free human being. -RI Safir 2013

-------------- next part --------------
[   982.655] 
X.Org X Server 1.20.0
X Protocol Version 11, Revision 0
[   982.655] Build Operating System: Linux Artix Linux
[   982.655] Current Operating System: Linux flatbush 4.6.7-1-MANJARO #1 SMP PREEMPT Tue Aug 16 19:20:55 UTC 2016 x86_64
[   982.655] Kernel command line: BOOT_IMAGE=/vmlinuz-4.6-x86_64 root=UUID=69796a26-1d8a-4b5d-8cb2-d288b9aac0ee rw
[   982.655] Build Date: 18 June 2018  07:52:10PM
[   982.655]  
[   982.655] Current version of pixman: 0.34.0
[   982.655] 	Before reporting problems, check http://wiki.x.org
	to make sure that you have the latest version.
[   982.655] Markers: (--) probed, (**) from config file, (==) default setting,
	(++) from command line, (!!) notice, (II) informational,
	(WW) warning, (EE) error, (NI) not implemented, (??) unknown.
[   982.655] (==) Log file: "/var/log/Xorg.0.log", Time: Wed Jun 27 14:54:18 2018
[   982.655] (==) Using config directory: "/etc/X11/xorg.conf.d"
[   982.655] (==) Using system config directory "/usr/share/X11/xorg.conf.d"
[   982.656] (==) No Layout section.  Using the first Screen section.
[   982.656] (==) No screen section available. Using defaults.
[   982.656] (**) |-->Screen "Default Screen Section" (0)
[   982.656] (**) |   |-->Monitor "<default monitor>"
[   982.656] (==) No device specified for screen "Default Screen Section".
	Using the first device section listed.
[   982.656] (**) |   |-->Device "Device0"
[   982.656] (==) No monitor specified for screen "Default Screen Section".
	Using a default monitor configuration.
[   982.656] (==) Automatically adding devices
[   982.656] (==) Automatically enabling devices
[   982.656] (==) Automatically adding GPU devices
[   982.656] (==) Automatically binding GPU devices
[   982.656] (==) Max clients allowed: 256, resource mask: 0x1fffff
[   982.656] (WW) `fonts.dir' not found (or not valid) in "/usr/share/fonts/misc".
[   982.656] 	Entry deleted from font path.
[   982.656] 	(Run 'mkfontdir' on "/usr/share/fonts/misc").
[   982.656] (WW) `fonts.dir' not found (or not valid) in "/usr/share/fonts/Type1".
[   982.656] 	Entry deleted from font path.
[   982.656] 	(Run 'mkfontdir' on "/usr/share/fonts/Type1").
[   982.656] (==) FontPath set to:
	/usr/share/fonts/TTF,
	/usr/share/fonts/OTF,
	/usr/share/fonts/100dpi,
	/usr/share/fonts/75dpi
[   982.656] (==) ModulePath set to "/usr/lib/xorg/modules"
[   982.656] (WW) Ignoring unrecognized extension "Composite"
[   982.656] (**) Extension "RENDER" is enabled
[   982.657] (II) The server relies on udev to provide the list of input devices.
	If no devices become available, reconfigure udev or disable AutoAddDevices.
[   982.657] (II) Module ABI versions:
[   982.657] 	X.Org ANSI C Emulation: 0.4
[   982.657] 	X.Org Video Driver: 24.0
[   982.657] 	X.Org XInput driver : 24.1
[   982.657] 	X.Org Server Extension : 10.0
[   982.658] (--) using VT number 7

[   982.658] (II) systemd-logind: logind integration requires -keeptty and -keeptty was not provided, disabling logind integration
[   982.658] (II) xfree86: Adding drm device (/dev/dri/card0)
[   982.661] (--) PCI:*(0 at 0:2:0) 8086:1912:103c:802f rev 6, Mem @ 0xd0000000/16777216, 0xc0000000/268435456, I/O @ 0x00003000/64, BIOS @ 0x????????/131072
[   982.661] (II) Open ACPI successful (/var/run/acpid.socket)
[   982.661] (II) LoadModule: "glx"
[   982.661] (II) Loading /usr/lib/xorg/modules/extensions/libglx.so
[   982.663] (II) Module glx: vendor="X.Org Foundation"
[   982.663] 	compiled for 1.20.0, module version = 1.0.0
[   982.663] 	ABI class: X.Org Server Extension, version 10.0
[   982.663] (II) LoadModule: "intel"
[   982.663] (II) Loading /usr/lib/xorg/modules/drivers/intel_drv.so
[   982.664] (II) Module intel: vendor="X.Org Foundation"
[   982.664] 	compiled for 1.20.0, module version = 2.99.917
[   982.664] 	Module class: X.Org Video Driver
[   982.664] 	ABI class: X.Org Video Driver, version 24.0
[   982.664] (II) intel: Driver for Intel(R) Integrated Graphics Chipsets:
	i810, i810-dc100, i810e, i815, i830M, 845G, 854, 852GM/855GM, 865G,
	915G, E7221 (i915), 915GM, 945G, 945GM, 945GME, Pineview GM,
	Pineview G, 965G, G35, 965Q, 946GZ, 965GM, 965GME/GLE, G33, Q35, Q33,
	GM45, 4 Series, G45/G43, Q45/Q43, G41, B43
[   982.664] (II) intel: Driver for Intel(R) HD Graphics
[   982.664] (II) intel: Driver for Intel(R) Iris(TM) Graphics
[   982.664] (II) intel: Driver for Intel(R) Iris(TM) Pro Graphics
[   982.664] (WW) xf86OpenConsole: setpgid failed: Operation not permitted
[   982.664] (WW) xf86OpenConsole: setsid failed: Operation not permitted
[   982.675] (II) intel(0): Using Kernel Mode Setting driver: i915, version 1.6.0 20160229
[   982.675] (II) intel(0): SNA compiled from 2.99.917-831-ge7bfc906
[   982.676] (--) intel(0): Integrated Graphics Chipset: Intel(R) HD Graphics 530
[   982.676] (--) intel(0): CPU: x86-64, sse2, sse3, ssse3, sse4.1, sse4.2, avx, avx2; using a maximum of 4 threads
[   982.676] (II) intel(0): Creating default Display subsection in Screen section
	"Default Screen Section" for depth/fbbpp 24/32
[   982.676] (==) intel(0): Depth 24, (--) framebuffer bpp 32
[   982.676] (==) intel(0): RGB weight 888
[   982.676] (==) intel(0): Default visual is TrueColor
[   982.676] (**) intel(0): Option "AccelMethod" "sna"
[   982.676] (**) intel(0): Option "DRI" "true"
[   982.677] (II) intel(0): Output HDMI1 has no monitor section
[   982.677] (II) intel(0): Enabled output HDMI1
[   982.677] (II) intel(0): Output DP1 has no monitor section
[   982.677] (II) intel(0): Enabled output DP1
[   982.677] (II) intel(0): Output HDMI2 has no monitor section
[   982.677] (II) intel(0): Enabled output HDMI2
[   982.677] (II) intel(0): Output DP2 has no monitor section
[   982.677] (II) intel(0): Enabled output DP2
[   982.677] (II) intel(0): Output HDMI3 has no monitor section
[   982.678] (II) intel(0): Enabled output HDMI3
[   982.678] (--) intel(0): Using a maximum size of 256x256 for hardware cursors
[   982.678] (II) intel(0): Output VIRTUAL1 has no monitor section
[   982.678] (II) intel(0): Enabled output VIRTUAL1
[   982.678] (--) intel(0): Output HDMI1 using initial mode 1920x1080 on pipe 0
[   982.678] (==) intel(0): TearFree disabled
[   982.678] (==) intel(0): Using gamma correction (1.0, 1.0, 1.0)
[   982.678] (==) intel(0): DPI set to (96, 96)
[   982.678] (II) Loading sub module "dri3"
[   982.678] (II) LoadModule: "dri3"
[   982.678] (II) Module "dri3" already built-in
[   982.678] (II) Loading sub module "dri2"
[   982.678] (II) LoadModule: "dri2"
[   982.678] (II) Module "dri2" already built-in
[   982.678] (II) Loading sub module "present"
[   982.678] (II) LoadModule: "present"
[   982.678] (II) Module "present" already built-in
[   982.679] (II) intel(0): SNA initialized with Skylake (gen9) backend
[   982.679] (==) intel(0): Backing store enabled
[   982.679] (==) intel(0): Silken mouse disabled
[   982.679] (II) intel(0): HW Cursor enabled
[   982.679] (==) intel(0): DPMS enabled
[   982.679] (==) intel(0): Display hotplug detection enabled
[   982.679] (II) intel(0): [DRI2] Setup complete
[   982.679] (II) intel(0): [DRI2]   DRI driver: i965
[   982.679] (II) intel(0): [DRI2]   VDPAU driver: va_gl
[   982.679] (II) intel(0): direct rendering: DRI2 DRI3 enabled
[   982.679] (II) intel(0): hardware support for Present enabled
[   982.679] (II) Initializing extension Generic Event Extension
[   982.680] (II) Initializing extension SHAPE
[   982.680] (II) Initializing extension MIT-SHM
[   982.680] (II) Initializing extension XInputExtension
[   982.680] (II) Initializing extension XTEST
[   982.680] (II) Initializing extension BIG-REQUESTS
[   982.680] (II) Initializing extension SYNC
[   982.680] (II) Initializing extension XKEYBOARD
[   982.680] (II) Initializing extension XC-MISC
[   982.680] (II) Initializing extension SECURITY
[   982.680] (II) Initializing extension XFIXES
[   982.681] (II) Initializing extension RENDER
[   982.681] (II) Initializing extension RANDR
[   982.681] (II) Initializing extension COMPOSITE
[   982.681] (II) Initializing extension DAMAGE
[   982.681] (II) Initializing extension MIT-SCREEN-SAVER
[   982.681] (II) Initializing extension DOUBLE-BUFFER
[   982.681] (II) Initializing extension RECORD
[   982.681] (II) Initializing extension DPMS
[   982.681] (II) Initializing extension Present
[   982.681] (II) Initializing extension DRI3
[   982.681] (II) Initializing extension X-Resource
[   982.681] (II) Initializing extension XVideo
[   982.681] (II) Initializing extension XVideo-MotionCompensation
[   982.681] (II) Initializing extension GLX
[   982.687] (II) AIGLX: Loaded and initialized i965
[   982.687] (II) GLX: Initialized DRI2 GL provider for screen 0
[   982.687] (II) Initializing extension XFree86-VidModeExtension
[   982.687] (II) Initializing extension XFree86-DGA
[   982.687] (II) Initializing extension XFree86-DRI
[   982.687] (II) Initializing extension DRI2
[   982.689] (II) intel(0): switch to mode 1920x1080 at 60.0 on HDMI1 using pipe 0, position (0, 0), rotation normal, reflection none
[   982.689] (II) intel(0): Setting screen physical size to 508 x 285
[   982.722] (II) config/udev: Adding input device Power Button (/dev/input/event2)
[   982.722] (**) Power Button: Applying InputClass "evdev keyboard catchall"
[   982.722] (**) Power Button: Applying InputClass "libinput keyboard catchall"
[   982.722] (**) Power Button: Applying InputClass "system-keyboard"
[   982.722] (**) Power Button: Applying InputClass "Keyboard Defaults"
[   982.722] (II) LoadModule: "libinput"
[   982.722] (II) Loading /usr/lib/xorg/modules/input/libinput_drv.so
[   982.724] (EE) Failed to load /usr/lib/xorg/modules/input/libinput_drv.so: /usr/lib/libinput.so.10: undefined symbol: libwacom_get_button_evdev_code
[   982.724] (EE) Failed to load module "libinput" (loader failed, 0)
[   982.724] (EE) No input driver matching `libinput'
[   982.724] (II) Falling back to input driver `libinput'
[   982.724] (II) LoadModule: "libinput"
[   982.724] (II) Loading /usr/lib/xorg/modules/input/libinput_drv.so
[   982.724] (EE) Failed to load /usr/lib/xorg/modules/input/libinput_drv.so: /usr/lib/libinput.so.10: undefined symbol: libwacom_get_button_evdev_code
[   982.724] (EE) Failed to load module "libinput" (loader failed, 0)
[   982.724] (II) config/udev: Adding input device Video Bus (/dev/input/event7)
[   982.724] (**) Video Bus: Applying InputClass "evdev keyboard catchall"
[   982.724] (**) Video Bus: Applying InputClass "libinput keyboard catchall"
[   982.724] (**) Video Bus: Applying InputClass "system-keyboard"
[   982.724] (**) Video Bus: Applying InputClass "Keyboard Defaults"
[   982.724] (II) LoadModule: "libinput"
[   982.724] (II) Loading /usr/lib/xorg/modules/input/libinput_drv.so
[   982.724] (EE) Failed to load /usr/lib/xorg/modules/input/libinput_drv.so: /usr/lib/libinput.so.10: undefined symbol: libwacom_get_button_evdev_code
[   982.724] (EE) Failed to load module "libinput" (loader failed, 0)
[   982.724] (EE) No input driver matching `libinput'
[   982.724] (II) Falling back to input driver `libinput'
[   982.724] (II) LoadModule: "libinput"
[   982.724] (II) Loading /usr/lib/xorg/modules/input/libinput_drv.so
[   982.725] (EE) Failed to load /usr/lib/xorg/modules/input/libinput_drv.so: /usr/lib/libinput.so.10: undefined symbol: libwacom_get_button_evdev_code
[   982.725] (EE) Failed to load module "libinput" (loader failed, 0)
[   982.725] (II) config/udev: Adding input device Power Button (/dev/input/event1)
[   982.725] (**) Power Button: Applying InputClass "evdev keyboard catchall"
[   982.725] (**) Power Button: Applying InputClass "libinput keyboard catchall"
[   982.725] (**) Power Button: Applying InputClass "system-keyboard"
[   982.725] (**) Power Button: Applying InputClass "Keyboard Defaults"
[   982.725] (II) LoadModule: "libinput"
[   982.725] (II) Loading /usr/lib/xorg/modules/input/libinput_drv.so
[   982.725] (EE) Failed to load /usr/lib/xorg/modules/input/libinput_drv.so: /usr/lib/libinput.so.10: undefined symbol: libwacom_get_button_evdev_code
[   982.725] (EE) Failed to load module "libinput" (loader failed, 0)
[   982.725] (EE) No input driver matching `libinput'
[   982.725] (II) Falling back to input driver `libinput'
[   982.725] (II) LoadModule: "libinput"
[   982.725] (II) Loading /usr/lib/xorg/modules/input/libinput_drv.so
[   982.725] (EE) Failed to load /usr/lib/xorg/modules/input/libinput_drv.so: /usr/lib/libinput.so.10: undefined symbol: libwacom_get_button_evdev_code
[   982.725] (EE) Failed to load module "libinput" (loader failed, 0)
[   982.725] (II) config/udev: Adding input device Sleep Button (/dev/input/event0)
[   982.725] (**) Sleep Button: Applying InputClass "evdev keyboard catchall"
[   982.725] (**) Sleep Button: Applying InputClass "libinput keyboard catchall"
[   982.725] (**) Sleep Button: Applying InputClass "system-keyboard"
[   982.725] (**) Sleep Button: Applying InputClass "Keyboard Defaults"
[   982.725] (II) LoadModule: "libinput"
[   982.725] (II) Loading /usr/lib/xorg/modules/input/libinput_drv.so
[   982.726] (EE) Failed to load /usr/lib/xorg/modules/input/libinput_drv.so: /usr/lib/libinput.so.10: undefined symbol: libwacom_get_button_evdev_code
[   982.726] (EE) Failed to load module "libinput" (loader failed, 0)
[   982.726] (EE) No input driver matching `libinput'
[   982.726] (II) Falling back to input driver `libinput'
[   982.726] (II) LoadModule: "libinput"
[   982.726] (II) Loading /usr/lib/xorg/modules/input/libinput_drv.so
[   982.726] (EE) Failed to load /usr/lib/xorg/modules/input/libinput_drv.so: /usr/lib/libinput.so.10: undefined symbol: libwacom_get_button_evdev_code
[   982.726] (EE) Failed to load module "libinput" (loader failed, 0)
[   982.726] (II) config/udev: Adding input device SIGMACHIP Usb Mouse (/dev/input/event3)
[   982.726] (**) SIGMACHIP Usb Mouse: Applying InputClass "evdev pointer catchall"
[   982.726] (**) SIGMACHIP Usb Mouse: Applying InputClass "libinput pointer catchall"
[   982.726] (II) LoadModule: "libinput"
[   982.726] (II) Loading /usr/lib/xorg/modules/input/libinput_drv.so
[   982.726] (EE) Failed to load /usr/lib/xorg/modules/input/libinput_drv.so: /usr/lib/libinput.so.10: undefined symbol: libwacom_get_button_evdev_code
[   982.726] (EE) Failed to load module "libinput" (loader failed, 0)
[   982.726] (EE) No input driver matching `libinput'
[   982.726] (II) Falling back to input driver `libinput'
[   982.726] (II) LoadModule: "libinput"
[   982.726] (II) Loading /usr/lib/xorg/modules/input/libinput_drv.so
[   982.727] (EE) Failed to load /usr/lib/xorg/modules/input/libinput_drv.so: /usr/lib/libinput.so.10: undefined symbol: libwacom_get_button_evdev_code
[   982.727] (EE) Failed to load module "libinput" (loader failed, 0)
[   982.727] (II) config/udev: Adding input device SIGMACHIP Usb Mouse (/dev/input/mouse0)
[   982.727] (II) No input driver specified, ignoring this device.
[   982.727] (II) This device may have been added with another device file.
[   982.727] (II) config/udev: Adding input device GASIA USB KB V11 (/dev/input/event4)
[   982.727] (**) GASIA USB KB V11: Applying InputClass "evdev keyboard catchall"
[   982.727] (**) GASIA USB KB V11: Applying InputClass "libinput keyboard catchall"
[   982.727] (**) GASIA USB KB V11: Applying InputClass "system-keyboard"
[   982.727] (**) GASIA USB KB V11: Applying InputClass "Keyboard Defaults"
[   982.727] (II) LoadModule: "libinput"
[   982.727] (II) Loading /usr/lib/xorg/modules/input/libinput_drv.so
[   982.727] (EE) Failed to load /usr/lib/xorg/modules/input/libinput_drv.so: /usr/lib/libinput.so.10: undefined symbol: libwacom_get_button_evdev_code
[   982.727] (EE) Failed to load module "libinput" (loader failed, 0)
[   982.727] (EE) No input driver matching `libinput'
[   982.727] (II) Falling back to input driver `libinput'
[   982.727] (II) LoadModule: "libinput"
[   982.727] (II) Loading /usr/lib/xorg/modules/input/libinput_drv.so
[   982.727] (EE) Failed to load /usr/lib/xorg/modules/input/libinput_drv.so: /usr/lib/libinput.so.10: undefined symbol: libwacom_get_button_evdev_code
[   982.727] (EE) Failed to load module "libinput" (loader failed, 0)
[   982.728] (II) config/udev: Adding input device GASIA USB KB V11 (/dev/input/event5)
[   982.728] (**) GASIA USB KB V11: Applying InputClass "evdev keyboard catchall"
[   982.728] (**) GASIA USB KB V11: Applying InputClass "libinput keyboard catchall"
[   982.728] (**) GASIA USB KB V11: Applying InputClass "system-keyboard"
[   982.728] (**) GASIA USB KB V11: Applying InputClass "Keyboard Defaults"
[   982.728] (II) LoadModule: "libinput"
[   982.728] (II) Loading /usr/lib/xorg/modules/input/libinput_drv.so
[   982.728] (EE) Failed to load /usr/lib/xorg/modules/input/libinput_drv.so: /usr/lib/libinput.so.10: undefined symbol: libwacom_get_button_evdev_code
[   982.728] (EE) Failed to load module "libinput" (loader failed, 0)
[   982.728] (EE) No input driver matching `libinput'
[   982.728] (II) Falling back to input driver `libinput'
[   982.728] (II) LoadModule: "libinput"
[   982.728] (II) Loading /usr/lib/xorg/modules/input/libinput_drv.so
[   982.728] (EE) Failed to load /usr/lib/xorg/modules/input/libinput_drv.so: /usr/lib/libinput.so.10: undefined symbol: libwacom_get_button_evdev_code
[   982.728] (EE) Failed to load module "libinput" (loader failed, 0)
[   982.728] (II) config/udev: Adding input device HDA Digital PCBeep (/dev/input/event8)
[   982.728] (II) No input driver specified, ignoring this device.
[   982.728] (II) This device may have been added with another device file.
[   982.728] (II) config/udev: Adding input device HDA Intel PCH Front Mic (/dev/input/event9)
[   982.728] (II) No input driver specified, ignoring this device.
[   982.728] (II) This device may have been added with another device file.
[   982.728] (II) config/udev: Adding input device HDA Intel PCH Rear Mic (/dev/input/event10)
[   982.728] (II) No input driver specified, ignoring this device.
[   982.728] (II) This device may have been added with another device file.
[   982.728] (II) config/udev: Adding input device HDA Intel PCH Line (/dev/input/event11)
[   982.728] (II) No input driver specified, ignoring this device.
[   982.728] (II) This device may have been added with another device file.
[   982.729] (II) config/udev: Adding input device HDA Intel PCH Line Out (/dev/input/event12)
[   982.729] (II) No input driver specified, ignoring this device.
[   982.729] (II) This device may have been added with another device file.
[   982.729] (II) config/udev: Adding input device HDA Intel PCH Front Headphone (/dev/input/event13)
[   982.729] (II) No input driver specified, ignoring this device.
[   982.729] (II) This device may have been added with another device file.
[   982.729] (II) config/udev: Adding input device HDA Intel PCH HDMI/DP,pcm=3 (/dev/input/event14)
[   982.729] (II) No input driver specified, ignoring this device.
[   982.729] (II) This device may have been added with another device file.
[   982.729] (II) config/udev: Adding input device HDA Intel PCH HDMI/DP,pcm=7 (/dev/input/event15)
[   982.729] (II) No input driver specified, ignoring this device.
[   982.729] (II) This device may have been added with another device file.
[   982.729] (II) config/udev: Adding input device HP WMI hotkeys (/dev/input/event6)
[   982.729] (**) HP WMI hotkeys: Applying InputClass "evdev keyboard catchall"
[   982.729] (**) HP WMI hotkeys: Applying InputClass "libinput keyboard catchall"
[   982.729] (**) HP WMI hotkeys: Applying InputClass "system-keyboard"
[   982.729] (**) HP WMI hotkeys: Applying InputClass "Keyboard Defaults"
[   982.729] (II) LoadModule: "libinput"
[   982.729] (II) Loading /usr/lib/xorg/modules/input/libinput_drv.so
[   982.729] (EE) Failed to load /usr/lib/xorg/modules/input/libinput_drv.so: /usr/lib/libinput.so.10: undefined symbol: libwacom_get_button_evdev_code
[   982.729] (EE) Failed to load module "libinput" (loader failed, 0)
[   982.729] (EE) No input driver matching `libinput'
[   982.729] (II) Falling back to input driver `libinput'
[   982.729] (II) LoadModule: "libinput"
[   982.729] (II) Loading /usr/lib/xorg/modules/input/libinput_drv.so
[   982.729] (EE) Failed to load /usr/lib/xorg/modules/input/libinput_drv.so: /usr/lib/libinput.so.10: undefined symbol: libwacom_get_button_evdev_code
[   982.729] (EE) Failed to load module "libinput" (loader failed, 0)
[   987.516] (II) config/udev: Adding input device SIGMACHIP Usb Mouse (/dev/input/mouse0)
[   987.516] (II) No input driver specified, ignoring this device.
[   987.516] (II) This device may have been added with another device file.
[   987.576] (II) config/udev: Adding input device SIGMACHIP Usb Mouse (/dev/input/event3)
[   987.576] (**) SIGMACHIP Usb Mouse: Applying InputClass "evdev pointer catchall"
[   987.576] (**) SIGMACHIP Usb Mouse: Applying InputClass "libinput pointer catchall"
[   987.576] (II) LoadModule: "libinput"
[   987.577] (II) Loading /usr/lib/xorg/modules/input/libinput_drv.so
[   987.578] (EE) Failed to load /usr/lib/xorg/modules/input/libinput_drv.so: /usr/lib/libinput.so.10: undefined symbol: libwacom_get_button_evdev_code
[   987.578] (EE) Failed to load module "libinput" (loader failed, 0)
[   987.578] (EE) No input driver matching `libinput'
[   987.578] (II) Falling back to input driver `libinput'
[   987.578] (II) LoadModule: "libinput"
[   987.578] (II) Loading /usr/lib/xorg/modules/input/libinput_drv.so
[   987.579] (EE) Failed to load /usr/lib/xorg/modules/input/libinput_drv.so: /usr/lib/libinput.so.10: undefined symbol: libwacom_get_button_evdev_code
[   987.579] (EE) Failed to load module "libinput" (loader failed, 0)
[  1010.112] (II) config/udev: Adding input device SIGMACHIP Usb Mouse (/dev/input/mouse0)
[  1010.112] (II) No input driver specified, ignoring this device.
[  1010.112] (II) This device may have been added with another device file.
[  1010.173] (II) config/udev: Adding input device SIGMACHIP Usb Mouse (/dev/input/event3)
[  1010.173] (**) SIGMACHIP Usb Mouse: Applying InputClass "evdev pointer catchall"
[  1010.173] (**) SIGMACHIP Usb Mouse: Applying InputClass "libinput pointer catchall"
[  1010.173] (II) LoadModule: "libinput"
[  1010.174] (II) Loading /usr/lib/xorg/modules/input/libinput_drv.so
[  1010.175] (EE) Failed to load /usr/lib/xorg/modules/input/libinput_drv.so: /usr/lib/libinput.so.10: undefined symbol: libwacom_get_button_evdev_code
[  1010.175] (EE) Failed to load module "libinput" (loader failed, 0)
[  1010.175] (EE) No input driver matching `libinput'
[  1010.175] (II) Falling back to input driver `libinput'
[  1010.175] (II) LoadModule: "libinput"
[  1010.175] (II) Loading /usr/lib/xorg/modules/input/libinput_drv.so
[  1010.176] (EE) Failed to load /usr/lib/xorg/modules/input/libinput_drv.so: /usr/lib/libinput.so.10: undefined symbol: libwacom_get_button_evdev_code
[  1010.176] (EE) Failed to load module "libinput" (loader failed, 0)
[  1013.062] (II) config/udev: Adding input device SIGMACHIP Usb Mouse (/dev/input/mouse0)
[  1013.062] (II) No input driver specified, ignoring this device.
[  1013.062] (II) This device may have been added with another device file.
[  1013.117] (II) config/udev: Adding input device SIGMACHIP Usb Mouse (/dev/input/event3)
[  1013.117] (**) SIGMACHIP Usb Mouse: Applying InputClass "evdev pointer catchall"
[  1013.117] (**) SIGMACHIP Usb Mouse: Applying InputClass "libinput pointer catchall"
[  1013.117] (II) LoadModule: "libinput"
[  1013.117] (II) Loading /usr/lib/xorg/modules/input/libinput_drv.so
[  1013.118] (EE) Failed to load /usr/lib/xorg/modules/input/libinput_drv.so: /usr/lib/libinput.so.10: undefined symbol: libwacom_get_button_evdev_code
[  1013.118] (EE) Failed to load module "libinput" (loader failed, 0)
[  1013.118] (EE) No input driver matching `libinput'
[  1013.118] (II) Falling back to input driver `libinput'
[  1013.118] (II) LoadModule: "libinput"
[  1013.118] (II) Loading /usr/lib/xorg/modules/input/libinput_drv.so
[  1013.119] (EE) Failed to load /usr/lib/xorg/modules/input/libinput_drv.so: /usr/lib/libinput.so.10: undefined symbol: libwacom_get_button_evdev_code
[  1013.119] (EE) Failed to load module "libinput" (loader failed, 0)
[  1018.775] (II) config/udev: Adding input device SIGMACHIP Usb Mouse (/dev/input/mouse0)
[  1018.775] (II) No input driver specified, ignoring this device.
[  1018.775] (II) This device may have been added with another device file.
[  1018.813] (II) config/udev: Adding input device SIGMACHIP Usb Mouse (/dev/input/event3)
[  1018.813] (**) SIGMACHIP Usb Mouse: Applying InputClass "evdev pointer catchall"
[  1018.813] (**) SIGMACHIP Usb Mouse: Applying InputClass "libinput pointer catchall"
[  1018.813] (II) LoadModule: "libinput"
[  1018.814] (II) Loading /usr/lib/xorg/modules/input/libinput_drv.so
[  1018.815] (EE) Failed to load /usr/lib/xorg/modules/input/libinput_drv.so: /usr/lib/libinput.so.10: undefined symbol: libwacom_get_button_evdev_code
[  1018.815] (EE) Failed to load module "libinput" (loader failed, 0)
[  1018.815] (EE) No input driver matching `libinput'
[  1018.815] (II) Falling back to input driver `libinput'
[  1018.815] (II) LoadModule: "libinput"
[  1018.815] (II) Loading /usr/lib/xorg/modules/input/libinput_drv.so
[  1018.816] (EE) Failed to load /usr/lib/xorg/modules/input/libinput_drv.so: /usr/lib/libinput.so.10: undefined symbol: libwacom_get_button_evdev_code
[  1018.816] (EE) Failed to load module "libinput" (loader failed, 0)


More information about the artix-general mailing list