[artix-general] X11 Hosed and I'm really stuck

Ruben Safir ruben at mrbrklyn.com
Wed Jun 27 16:30:32 EEST 2018


This last update I did completely hosed X11.  I posted on the forum, but
without X I can't really do much on the forum.  I tried to start it by
hand and I am attaching the log file.

stdio doesn't work once lightdm is loaded.  It shows on the screen but
fails to take any input.

Ruben

-- 
So many immigrant groups have swept through our town
that Brooklyn, like Atlantis, reaches mythological
proportions in the mind of the world - RI Safir 1998
http://www.mrbrklyn.com 

DRM is THEFT - We are the STAKEHOLDERS - RI Safir 2002
http://www.nylxs.com - Leadership Development in Free Software
http://www2.mrbrklyn.com/resources - Unpublished Archive 
http://www.coinhangout.com - coins!
http://www.brooklyn-living.com 

Being so tracked is for FARM ANIMALS and and extermination camps, 
but incompatible with living as a free human being. -RI Safir 2013

-------------- next part --------------
[   381.719] (WW) Failed to open protocol names file lib/xorg/protocol.txt
[   381.721] 
X.Org X Server 1.20.0
X Protocol Version 11, Revision 0
[   381.723] Build Operating System: Linux Artix Linux
[   381.724] Current Operating System: Linux flatbush 4.1.43-1-MANJARO #1 SMP PREEMPT Sun Aug 6 14:15:25 UTC 2017 x86_64
[   381.724] Kernel command line: BOOT_IMAGE=/vmlinuz-4.1-x86_64 root=UUID=69796a26-1d8a-4b5d-8cb2-d288b9aac0ee rw
[   381.725] Build Date: 18 June 2018  07:52:10PM
[   381.725]  
[   381.725] Current version of pixman: 0.34.0
[   381.726] 	Before reporting problems, check http://wiki.x.org
	to make sure that you have the latest version.
[   381.726] Markers: (--) probed, (**) from config file, (==) default setting,
	(++) from command line, (!!) notice, (II) informational,
	(WW) warning, (EE) error, (NI) not implemented, (??) unknown.
[   381.728] (==) Log file: "/var/log/Xorg.0.log", Time: Wed Jun 27 09:23:27 2018
[   381.728] (==) Using config directory: "/etc/X11/xorg.conf.d"
[   381.728] (==) Using system config directory "/usr/share/X11/xorg.conf.d"
[   381.729] (==) No Layout section.  Using the first Screen section.
[   381.729] (==) No screen section available. Using defaults.
[   381.729] (**) |-->Screen "Default Screen Section" (0)
[   381.729] (**) |   |-->Monitor "<default monitor>"
[   381.729] (==) No device specified for screen "Default Screen Section".
	Using the first device section listed.
[   381.729] (**) |   |-->Device "Device0"
[   381.729] (==) No monitor specified for screen "Default Screen Section".
	Using a default monitor configuration.
[   381.729] (==) Automatically adding devices
[   381.729] (==) Automatically enabling devices
[   381.729] (==) Automatically adding GPU devices
[   381.729] (==) Automatically binding GPU devices
[   381.729] (==) Max clients allowed: 256, resource mask: 0x1fffff
[   381.729] (==) FontPath set to:
	/usr/share/fonts/misc,
	/usr/share/fonts/TTF,
	/usr/share/fonts/OTF,
	/usr/share/fonts/Type1,
	/usr/share/fonts/100dpi,
	/usr/share/fonts/75dpi
[   381.729] (==) ModulePath set to "/usr/lib/xorg/modules"
[   381.729] (WW) Ignoring unrecognized extension "Composite"
[   381.729] (**) Extension "RENDER" is enabled
[   381.729] (II) The server relies on udev to provide the list of input devices.
	If no devices become available, reconfigure udev or disable AutoAddDevices.
[   381.729] (II) Module ABI versions:
[   381.729] 	X.Org ANSI C Emulation: 0.4
[   381.729] 	X.Org Video Driver: 24.0
[   381.729] 	X.Org XInput driver : 24.1
[   381.729] 	X.Org Server Extension : 10.0
[   381.729] (--) using VT number 7

[   381.729] (II) systemd-logind: logind integration requires -keeptty and -keeptty was not provided, disabling logind integration
[   381.730] (--) PCI:*(0 at 0:2:0) 8086:1912:103c:802f rev 6, Mem @ 0xd0000000/16777216, 0xc0000000/268435456, I/O @ 0x00003000/64
[   381.730] (II) Open ACPI successful (/var/run/acpid.socket)
[   381.730] (II) LoadModule: "glx"
[   381.730] (II) Loading /usr/lib/xorg/modules/extensions/libglx.so
[   381.731] (II) Module glx: vendor="X.Org Foundation"
[   381.731] 	compiled for 1.20.0, module version = 1.0.0
[   381.731] 	ABI class: X.Org Server Extension, version 10.0
[   381.731] (II) LoadModule: "intel"
[   381.731] (II) Loading /usr/lib/xorg/modules/drivers/intel_drv.so
[   381.731] (II) Module intel: vendor="X.Org Foundation"
[   381.731] 	compiled for 1.20.0, module version = 2.99.917
[   381.731] 	Module class: X.Org Video Driver
[   381.731] 	ABI class: X.Org Video Driver, version 24.0
[   381.731] (II) intel: Driver for Intel(R) Integrated Graphics Chipsets:
	i810, i810-dc100, i810e, i815, i830M, 845G, 854, 852GM/855GM, 865G,
	915G, E7221 (i915), 915GM, 945G, 945GM, 945GME, Pineview GM,
	Pineview G, 965G, G35, 965Q, 946GZ, 965GM, 965GME/GLE, G33, Q35, Q33,
	GM45, 4 Series, G45/G43, Q45/Q43, G41, B43
[   381.731] (II) intel: Driver for Intel(R) HD Graphics
[   381.731] (II) intel: Driver for Intel(R) Iris(TM) Graphics
[   381.731] (II) intel: Driver for Intel(R) Iris(TM) Pro Graphics
[   383.764] intel: waited 2020 ms for i915.ko driver to load
[   385.802] intel: waited 2020 ms for i915.ko driver to load
[   385.805] (EE) No devices detected.
[   385.805] (EE) 
Fatal server error:
[   385.805] (EE) no screens found(EE) 
[   385.805] (EE) 
Please consult the The X.Org Foundation support 
	 at http://wiki.x.org
 for help. 
[   385.805] (EE) Please also check the log file at "/var/log/Xorg.0.log" for additional information.
[   385.805] (EE) 
[   385.812] (EE) Server terminated with error (1). Closing log file.


More information about the artix-general mailing list