[artix-build-failures] [galaxy-goblins] Failure: perl-acme-alien-dontpanic

jenkins at artixlinux.org jenkins at artixlinux.org
Sun Jun 21 23:23:18 CEST 2020


   Failure

   Build: x86_64/community-staging

   Packages:

   perl-acme-alien-dontpanic-2.1100-3-any.pkg.tar.zst

   author: alium

   email: alium at artixlinux.org

   [1]https://orion.artixlinux.org/job/packagesPerl/job/perl-acme-alien-do
   ntpanic/job/master/11/

References

   1. https://orion.artixlinux.org/job/packagesPerl/job/perl-acme-alien-dontpanic/job/master/11/
-------------- next part --------------
Started by user alium
Querying the current revision of branch master...
Current revision of branch master is 762f6c29a7318de32ddf8c1cb35d77822c61e015
Obtained Jenkinsfile from 762f6c29a7318de32ddf8c1cb35d77822c61e015
Running in Durability level: PERFORMANCE_OPTIMIZED
Loading library artix-ci at master
Attempting to resolve master from remote references...
 > git --version # timeout=10
 > git ls-remote -- https://gitea.artixlinux.org/artix/pipeline-libs.git # timeout=10
Found match: refs/heads/master revision d7992e76739bba40e5e57f4e22437a25787e3cb7
Warning: CredentialId "gitea-ci" could not be found.
 > git rev-parse --is-inside-work-tree # timeout=10
Fetching changes from the remote Git repository
 > git config remote.origin.url https://gitea.artixlinux.org/artix/pipeline-libs.git # timeout=10
Fetching without tags
Fetching upstream changes from https://gitea.artixlinux.org/artix/pipeline-libs.git
 > git --version # timeout=10
 > git fetch --no-tags --force --progress -- https://gitea.artixlinux.org/artix/pipeline-libs.git +refs/heads/master:refs/remotes/origin/master # timeout=10
Checking out Revision d7992e76739bba40e5e57f4e22437a25787e3cb7 (master)
 > git config core.sparsecheckout # timeout=10
 > git checkout -f d7992e76739bba40e5e57f4e22437a25787e3cb7 # timeout=10
Commit message: "adjust arch map"
[Gitea] Notifying branch build status: PENDING Build started...
[Gitea] Notified
[Pipeline] Start of Pipeline
[Pipeline] node
Running on Jenkins in /build/jenkins/workspace/perl-acme-alien-dontpanic_master
[Pipeline] {
[Pipeline] timestamps
[Pipeline] {
[Pipeline] stage
[Pipeline] { (Prepare)
[Pipeline] catchError
[Pipeline] {
[Pipeline] checkout
[2020-06-21T21:23:03.910Z] Warning: CredentialId "jenkins-ci" could not be found.
[2020-06-21T21:23:03.911Z]  > git rev-parse --is-inside-work-tree # timeout=10
[2020-06-21T21:23:03.915Z] Fetching changes from the remote Git repository
[2020-06-21T21:23:03.915Z]  > git config remote.origin.url https://237b7412742b4068af4173944de150f12959f4d3@gitea.artixlinux.org/packagesPerl/perl-acme-alien-dontpanic.git # timeout=10
[2020-06-21T21:23:03.920Z] Cleaning workspace
[2020-06-21T21:23:03.920Z]  > git rev-parse --verify HEAD # timeout=10
[2020-06-21T21:23:03.925Z] Resetting working tree
[2020-06-21T21:23:03.925Z]  > git reset --hard # timeout=10
[2020-06-21T21:23:03.931Z]  > git clean -fdx # timeout=10
[2020-06-21T21:23:03.937Z] Fetching without tags
[2020-06-21T21:23:03.937Z] Fetching upstream changes from https://237b7412742b4068af4173944de150f12959f4d3@gitea.artixlinux.org/packagesPerl/perl-acme-alien-dontpanic.git
[2020-06-21T21:23:03.937Z]  > git --version # timeout=10
[2020-06-21T21:23:03.941Z]  > git fetch --no-tags --force --progress -- https://237b7412742b4068af4173944de150f12959f4d3@gitea.artixlinux.org/packagesPerl/perl-acme-alien-dontpanic.git +refs/heads/master:refs/remotes/origin/master # timeout=10
[2020-06-21T21:23:04.057Z] Checking out Revision 762f6c29a7318de32ddf8c1cb35d77822c61e015 (master)
[2020-06-21T21:23:04.057Z]  > git config core.sparsecheckout # timeout=10
[2020-06-21T21:23:04.062Z]  > git checkout -f 762f6c29a7318de32ddf8c1cb35d77822c61e015 # timeout=10
[2020-06-21T21:23:04.069Z] Commit message: "[trunk] -> [community-staging] 'perl-acme-alien-dontpanic-2.1100-3' add"
[2020-06-21T21:23:04.070Z]  > git rev-list --no-walk 762f6c29a7318de32ddf8c1cb35d77822c61e015 # timeout=10
[2020-06-21T21:23:04.081Z] [Gitea] Notifying branch build status: PENDING Build started...
[2020-06-21T21:23:04.223Z] [Gitea] Notified
[Pipeline] libraryResource
[Pipeline] readYaml
[Pipeline] sh
[2020-06-21T21:23:04.499Z] + git show -s --format=%an 762f6c29a7318de32ddf8c1cb35d77822c61e015
[Pipeline] sh
[2020-06-21T21:23:04.757Z] + git show -s --format=%ae 762f6c29a7318de32ddf8c1cb35d77822c61e015
[Pipeline] sh
[2020-06-21T21:23:05.015Z] + git show --pretty=format: --name-status 762f6c29a7318de32ddf8c1cb35d77822c61e015
[Pipeline] fileExists
[Pipeline] sh
[2020-06-21T21:23:05.286Z] + pkg2yaml -d x86_64/community-staging
[Pipeline] readYaml
[Pipeline] echo
[2020-06-21T21:23:05.305Z] isNextLayout: true
[Pipeline] }
[Pipeline] // catchError
[Pipeline] }
[Pipeline] // stage
[Pipeline] stage
[Pipeline] { (Build)
[Pipeline] withCredentials
[2020-06-21T21:23:05.449Z] Masking supported pattern matches of $BUILDBOT_GPGP
[Pipeline] {
[Pipeline] echo
[2020-06-21T21:23:05.478Z] isLibBump: false
[Pipeline] dir
[2020-06-21T21:23:05.483Z] Running in /build/jenkins/workspace/perl-acme-alien-dontpanic_master/x86_64/community-staging
[Pipeline] {
[Pipeline] catchError
[Pipeline] {
[Pipeline] sh
[2020-06-21T21:23:05.752Z] + buildpkg -C -d galaxy-goblins
[2020-06-21T21:23:08.979Z] :: Synchronizing package databases...
[2020-06-21T21:23:08.979Z]  goblins is up to date
[2020-06-21T21:23:08.979Z]  gremlins is up to date
[2020-06-21T21:23:08.979Z]  system is up to date
[2020-06-21T21:23:08.979Z]  world is up to date
[2020-06-21T21:23:08.979Z] downloading galaxy-goblins.db...
[2020-06-21T21:23:08.979Z]  galaxy-gremlins is up to date
[2020-06-21T21:23:08.979Z]  galaxy is up to date
[2020-06-21T21:23:08.979Z]  staging is up to date
[2020-06-21T21:23:08.979Z]  testing is up to date
[2020-06-21T21:23:08.979Z]  extra is up to date
[2020-06-21T21:23:08.980Z]  community-staging is up to date
[2020-06-21T21:23:08.980Z]  community-testing is up to date
[2020-06-21T21:23:08.980Z]  community is up to date
[2020-06-21T21:23:08.980Z] :: Starting full system upgrade...
[2020-06-21T21:23:09.230Z]  there is nothing to do
[2020-06-21T21:23:10.141Z] ==> Building in chroot for [goblins] (x86_64)...
[2020-06-21T21:23:10.691Z] ==> Synchronizing chroot copy [/build/buildpkg/goblins-x86_64/root] -> [jenkins]...done
[2020-06-21T21:23:11.603Z] ==> Making package: perl-acme-alien-dontpanic 2.1100-3 (Sun Jun 21 23:23:11 2020)
[2020-06-21T21:23:11.603Z] ==> Retrieving sources...
[2020-06-21T21:23:11.603Z]   -> Found Acme-Alien-DontPanic-2.1100.tar.gz
[2020-06-21T21:23:11.603Z] ==> Validating source files with sha512sums...
[2020-06-21T21:23:11.603Z]     Acme-Alien-DontPanic-2.1100.tar.gz ... Passed
[2020-06-21T21:23:16.797Z] ==> Making package: perl-acme-alien-dontpanic 2.1100-3 (Sun 21 Jun 2020 09:23:15 PM UTC)
[2020-06-21T21:23:16.797Z] ==> Checking runtime dependencies...
[2020-06-21T21:23:16.797Z] ==> Installing missing dependencies...
[2020-06-21T21:23:16.797Z] resolving dependencies...
[2020-06-21T21:23:16.797Z] looking for conflicting packages...
[2020-06-21T21:23:16.797Z] 
[2020-06-21T21:23:16.797Z] Package (9)                    New Version  Net Change
[2020-06-21T21:23:16.797Z] 
[2020-06-21T21:23:16.797Z] goblins/perl-capture-tiny      0.48-4         0.03 MiB
[2020-06-21T21:23:16.797Z] goblins/perl-class-inspector   1.36-3         0.03 MiB
[2020-06-21T21:23:16.797Z] world/perl-ffi-checklib        0.27-1         0.02 MiB
[2020-06-21T21:23:16.797Z] galaxy/perl-file-chdir         0.1011-3       0.05 MiB
[2020-06-21T21:23:16.797Z] goblins/perl-file-which        1.23-4         0.02 MiB
[2020-06-21T21:23:16.797Z] galaxy-goblins/perl-path-tiny  0.112-2        0.12 MiB
[2020-06-21T21:23:16.797Z] community/dontpanic            1.02-1         0.03 MiB
[2020-06-21T21:23:16.797Z] goblins/perl-alien-build       2.26-3         0.65 MiB
[2020-06-21T21:23:16.797Z] goblins/perl-file-sharedir     1.116-4        0.02 MiB
[2020-06-21T21:23:16.797Z] 
[2020-06-21T21:23:16.797Z] Total Installed Size:  0.97 MiB
[2020-06-21T21:23:16.797Z] 
[2020-06-21T21:23:16.797Z] :: Proceed with installation? [Y/n] 
[2020-06-21T21:23:16.797Z] checking keyring...
[2020-06-21T21:23:16.797Z] checking package integrity...
[2020-06-21T21:23:16.797Z] loading package files...
[2020-06-21T21:23:16.797Z] checking for file conflicts...
[2020-06-21T21:23:16.797Z] checking available disk space...
[2020-06-21T21:23:16.797Z] :: Processing package changes...
[2020-06-21T21:23:16.797Z] installing dontpanic...
[2020-06-21T21:23:16.797Z] installing perl-capture-tiny...
[2020-06-21T21:23:16.797Z] installing perl-ffi-checklib...
[2020-06-21T21:23:16.797Z] installing perl-file-chdir...
[2020-06-21T21:23:16.797Z] installing perl-file-which...
[2020-06-21T21:23:16.797Z] installing perl-path-tiny...
[2020-06-21T21:23:16.797Z] installing perl-alien-build...
[2020-06-21T21:23:16.797Z] installing perl-class-inspector...
[2020-06-21T21:23:16.797Z] installing perl-file-sharedir...
[2020-06-21T21:23:16.797Z] :: Running post-transaction hooks...
[2020-06-21T21:23:16.797Z] (1/1) Warn about old perl modules
[2020-06-21T21:23:17.047Z] WARNING: '/usr/lib/perl5/5.30' contains data from at least 1 packages which will NOT be used by the installed perl interpreter.
[2020-06-21T21:23:17.047Z]  -> Run the following command to get a list of affected packages: pacman -Qqo '/usr/lib/perl5/5.30'
[2020-06-21T21:23:17.047Z] ==> Checking buildtime dependencies...
[2020-06-21T21:23:17.047Z] ==> Installing missing dependencies...
[2020-06-21T21:23:17.299Z] resolving dependencies...
[2020-06-21T21:23:17.299Z] looking for conflicting packages...
[2020-06-21T21:23:17.299Z] 
[2020-06-21T21:23:17.299Z] Package (16)                                New Version  Net Change
[2020-06-21T21:23:17.299Z] 
[2020-06-21T21:23:17.299Z] galaxy-goblins/perl-archive-extract         0.86-2         0.06 MiB
[2020-06-21T21:23:17.299Z] goblins/perl-html-parser                    3.72-10        0.16 MiB
[2020-06-21T21:23:17.299Z] goblins/perl-html-tagset                    3.20-10        0.02 MiB
[2020-06-21T21:23:17.299Z] galaxy-goblins/perl-importer                0.025-4        0.05 MiB
[2020-06-21T21:23:17.299Z] goblins/perl-inc-latest                     0.500-7        0.02 MiB
[2020-06-21T21:23:17.299Z] goblins/perl-module-build                   0.4231-3       0.37 MiB
[2020-06-21T21:23:17.299Z] galaxy-goblins/perl-module-pluggable        5.2-6          0.03 MiB
[2020-06-21T21:23:17.300Z] galaxy-goblins/perl-scope-guard             0.21-3         0.01 MiB
[2020-06-21T21:23:17.300Z] galaxy-goblins/perl-shell-config-generate   0.34-2         0.03 MiB
[2020-06-21T21:23:17.300Z] galaxy-goblins/perl-shell-guess             0.09-3         0.02 MiB
[2020-06-21T21:23:17.300Z] galaxy-goblins/perl-sort-versions           1.62-6         0.01 MiB
[2020-06-21T21:23:17.300Z] galaxy-goblins/perl-sub-info                0.002-7        0.01 MiB
[2020-06-21T21:23:17.300Z] galaxy-goblins/perl-term-table              0.015-2        0.05 MiB
[2020-06-21T21:23:17.300Z] goblins/perl-uri                            1.76-4         0.16 MiB
[2020-06-21T21:23:17.300Z] galaxy-goblins/perl-alien-base-modulebuild  1.14-3         0.11 MiB
[2020-06-21T21:23:17.300Z] galaxy-goblins/perl-test2-suite             0.000130-2     0.76 MiB
[2020-06-21T21:23:17.300Z] 
[2020-06-21T21:23:17.300Z] Total Installed Size:  1.85 MiB
[2020-06-21T21:23:17.300Z] 
[2020-06-21T21:23:17.300Z] :: Proceed with installation? [Y/n] 
[2020-06-21T21:23:17.300Z] checking keyring...
[2020-06-21T21:23:17.300Z] checking package integrity...
[2020-06-21T21:23:17.851Z] error: perl-alien-base-modulebuild: signature from "Artix Buildbot <buildbot at artixlinux.org>" is invalid
[2020-06-21T21:23:17.851Z] :: File /var/cache/pacman/pkg/perl-alien-base-modulebuild-1.14-3-any.pkg.tar.zst is corrupted (invalid or corrupted package (PGP signature)).
[2020-06-21T21:23:17.851Z] Do you want to delete it? [Y/n] error: failed to commit transaction (invalid or corrupted package)
[2020-06-21T21:23:17.851Z] 
[2020-06-21T21:23:17.852Z] Errors occurred, no packages were upgraded.
[2020-06-21T21:23:17.852Z] ==> ERROR: 'pacman' failed to install missing dependencies.
[2020-06-21T21:23:17.852Z] ==> Missing dependencies:
[2020-06-21T21:23:17.852Z]   -> perl-alien-base-modulebuild
[2020-06-21T21:23:17.852Z]   -> perl-test2-suite
[2020-06-21T21:23:17.852Z] ==> ERROR: Could not resolve all dependencies.
[2020-06-21T21:23:18.763Z] ==> ERROR: Build failed, check /build/buildpkg/goblins-x86_64/jenkins/build
[Pipeline] }
[2020-06-21T21:23:18.765Z] ERROR: Failed to build source
[2020-06-21T21:23:18.765Z] ERROR: script returned exit code 255
[Pipeline] // catchError
[Pipeline] }
[Pipeline] // dir
Post stage
[Pipeline] emailext
[2020-06-21T21:23:18.850Z] Sending email to: artix-build-failures at artixlinux.org


More information about the artix-build-failures mailing list