[artix-build-failures] [galaxy] Failure: python-u-msgpack

jenkins at artixlinux.org jenkins at artixlinux.org
Mon Apr 27 08:17:05 CEST 2020


   Failure

   Build: repos/community-any

   Packages:

   [python-u-msgpack-2.6.0-1-any.pkg.tar.xz,
   python2-u-msgpack-2.6.0-1-any.pkg.tar.xz]

   authorName: alium

   authorEmail: alium at artixlinux.org

   [1]https://orion.artixlinux.org/job/packagesPython/job/python-u-msgpack
   /job/master/7/

References

   1. https://orion.artixlinux.org/job/packagesPython/job/python-u-msgpack/job/master/7/
-------------- next part --------------
Push event to branch master
Querying the current revision of branch master...
Current revision of branch master is 621e6b863a9ef8dddf0ca7fdb8363e77d1042462
Obtained Jenkinsfile from 621e6b863a9ef8dddf0ca7fdb8363e77d1042462
Running in Durability level: PERFORMANCE_OPTIMIZED
Loading library artix-ci at master
Attempting to resolve master from remote references...
 > git --version # timeout=10
 > git ls-remote -- https://gitea.artixlinux.org/artix/pipeline-libs.git # timeout=10
Found match: refs/heads/master revision 77f77ff85eedb6eb60b64faf8c328ab86dbb479c
Warning: CredentialId "gitea-ci" could not be found.
 > git rev-parse --is-inside-work-tree # timeout=10
Fetching changes from the remote Git repository
 > git config remote.origin.url https://gitea.artixlinux.org/artix/pipeline-libs.git # timeout=10
Fetching without tags
Fetching upstream changes from https://gitea.artixlinux.org/artix/pipeline-libs.git
 > git --version # timeout=10
 > git fetch --no-tags --force --progress -- https://gitea.artixlinux.org/artix/pipeline-libs.git +refs/heads/master:refs/remotes/origin/master # timeout=10
Checking out Revision 77f77ff85eedb6eb60b64faf8c328ab86dbb479c (master)
 > git config core.sparsecheckout # timeout=10
 > git checkout -f 77f77ff85eedb6eb60b64faf8c328ab86dbb479c # timeout=10
Commit message: "Notify: remove fail condition"
[Gitea] Notifying branch build status: PENDING Build started...
[Gitea] Notified
[Pipeline] Start of Pipeline
[Pipeline] node
Running on Jenkins in /build/jenkins/workspace/esPython_python-u-msgpack_master
[Pipeline] {
[Pipeline] timestamps
[Pipeline] {
[Pipeline] stage
[Pipeline] { (Prepare)
[Pipeline] checkout
[2020-04-27T06:16:41.998Z] Warning: CredentialId "jenkins-ci" could not be found.
[2020-04-27T06:16:41.998Z]  > git rev-parse --is-inside-work-tree # timeout=10
[2020-04-27T06:16:42.008Z] Fetching changes from the remote Git repository
[2020-04-27T06:16:42.008Z]  > git config remote.origin.url https://237b7412742b4068af4173944de150f12959f4d3@gitea.artixlinux.org/packagesPython/python-u-msgpack.git # timeout=10
[2020-04-27T06:16:42.013Z] Cleaning workspace
[2020-04-27T06:16:42.013Z]  > git rev-parse --verify HEAD # timeout=10
[2020-04-27T06:16:42.018Z] Resetting working tree
[2020-04-27T06:16:42.018Z]  > git reset --hard # timeout=10
[2020-04-27T06:16:42.024Z]  > git clean -fdx # timeout=10
[2020-04-27T06:16:42.029Z] Fetching without tags
[2020-04-27T06:16:42.029Z] Fetching upstream changes from https://237b7412742b4068af4173944de150f12959f4d3@gitea.artixlinux.org/packagesPython/python-u-msgpack.git
[2020-04-27T06:16:42.029Z]  > git --version # timeout=10
[2020-04-27T06:16:42.033Z]  > git fetch --no-tags --force --progress -- https://237b7412742b4068af4173944de150f12959f4d3@gitea.artixlinux.org/packagesPython/python-u-msgpack.git +refs/heads/master:refs/remotes/origin/master # timeout=10
[2020-04-27T06:16:42.151Z] Checking out Revision 621e6b863a9ef8dddf0ca7fdb8363e77d1042462 (master)
[2020-04-27T06:16:42.151Z]  > git config core.sparsecheckout # timeout=10
[2020-04-27T06:16:42.155Z]  > git checkout -f 621e6b863a9ef8dddf0ca7fdb8363e77d1042462 # timeout=10
[2020-04-27T06:16:42.163Z] Commit message: "[trunk] -> [community] 'python-u-msgpack-2.6.0-1' add"
[2020-04-27T06:16:42.164Z]  > git rev-list --no-walk 761a8438458164b49ad01db5e0c9e4f56ace31e4 # timeout=10
[2020-04-27T06:16:42.175Z] [Gitea] Notifying branch build status: PENDING Build started...
[2020-04-27T06:16:42.348Z] [Gitea] Notified
[Pipeline] libraryResource
[Pipeline] readYaml
[Pipeline] sh
[2020-04-27T06:16:42.625Z] + git rev-parse @
[Pipeline] sh
[2020-04-27T06:16:42.880Z] + git show -s --format=%an 621e6b863a9ef8dddf0ca7fdb8363e77d1042462
[Pipeline] sh
[2020-04-27T06:16:43.137Z] + git show -s --format=%ae 621e6b863a9ef8dddf0ca7fdb8363e77d1042462
[Pipeline] sh
[2020-04-27T06:16:43.393Z] + git show --pretty=format: --name-status 621e6b863a9ef8dddf0ca7fdb8363e77d1042462
[Pipeline] fileExists
[Pipeline] sh
[2020-04-27T06:16:43.658Z] + pkg2yaml repos/community-any
[Pipeline] readYaml
[Pipeline] }
[Pipeline] // stage
[Pipeline] stage
[Pipeline] { (Build)
[Pipeline] echo
[2020-04-27T06:16:43.758Z] isRebuild: false
[Pipeline] dir
[2020-04-27T06:16:43.763Z] Running in /build/jenkins/workspace/esPython_python-u-msgpack_master/repos/community-any
[Pipeline] {
[Pipeline] sh
[2020-04-27T06:16:44.022Z] + buildpkg-galaxy
[2020-04-27T06:16:47.250Z] :: Synchronizing package databases...
[2020-04-27T06:16:47.250Z]  system is up to date
[2020-04-27T06:16:47.250Z]  world is up to date
[2020-04-27T06:16:47.250Z] downloading galaxy.db...
[2020-04-27T06:16:47.250Z]  extra is up to date
[2020-04-27T06:16:47.250Z] downloading community.db...
[2020-04-27T06:16:47.250Z] :: Starting full system upgrade...
[2020-04-27T06:16:47.250Z]  there is nothing to do
[2020-04-27T06:16:48.161Z] ==> Building in chroot for [default] (x86_64)...
[2020-04-27T06:16:49.072Z] ==> Synchronizing chroot copy [/build/buildpkg/default-x86_64/root] -> [jenkins]...done
[2020-04-27T06:16:50.415Z] ==> Making package: python-u-msgpack 2.6.0-1 (Mon Apr 27 08:16:50 2020)
[2020-04-27T06:16:50.415Z] ==> Retrieving sources...
[2020-04-27T06:16:50.415Z]   -> Found u-msgpack-python-2.6.0.tar.gz
[2020-04-27T06:16:50.415Z] ==> Validating source files with sha256sums...
[2020-04-27T06:16:50.415Z]     u-msgpack-python-2.6.0.tar.gz ... Passed
[2020-04-27T06:16:50.415Z] ==> Validating source files with b2sums...
[2020-04-27T06:16:50.415Z]     u-msgpack-python-2.6.0.tar.gz ... Passed
[2020-04-27T06:16:56.895Z] ==> Making package: python-u-msgpack 2.6.0-1 (Mon 27 Apr 2020 08:16:55 AM CEST)
[2020-04-27T06:16:56.895Z] ==> Checking runtime dependencies...
[2020-04-27T06:16:56.895Z] ==> Checking buildtime dependencies...
[2020-04-27T06:16:56.895Z] ==> Installing missing dependencies...
[2020-04-27T06:16:56.895Z] resolving dependencies...
[2020-04-27T06:16:56.895Z] looking for conflicting packages...
[2020-04-27T06:16:56.895Z] 
[2020-04-27T06:16:56.896Z] Package (44)                       New Version    Net Change  Download Size
[2020-04-27T06:16:56.896Z] 
[2020-04-27T06:16:56.896Z] system/libnsl                      1.2.0-2          0.19 MiB               
[2020-04-27T06:16:56.896Z] galaxy/python-apipkg               1.5-3            0.02 MiB               
[2020-04-27T06:16:56.896Z] world/python-appdirs               1.4.3-5          0.07 MiB               
[2020-04-27T06:16:56.896Z] galaxy/python-atomicwrites         1.3.0-3          0.03 MiB               
[2020-04-27T06:16:56.896Z] world/python-attrs                 19.3.0-4         0.30 MiB               
[2020-04-27T06:16:56.896Z] galaxy/python-importlib-metadata   1.5.1-1          0.18 MiB               
[2020-04-27T06:16:56.896Z] galaxy/python-iniconfig            1.0.0-4          0.02 MiB               
[2020-04-27T06:16:56.896Z] galaxy/python-more-itertools       8.2.0-1          0.25 MiB               
[2020-04-27T06:16:56.896Z] world/python-ordered-set           3.1.1-1          0.05 MiB               
[2020-04-27T06:16:56.896Z] world/python-packaging             20.3-1           0.17 MiB               
[2020-04-27T06:16:56.896Z] galaxy/python-pluggy               0.13.1-1         0.12 MiB               
[2020-04-27T06:16:56.896Z] galaxy/python-py                   1.8.1-1          0.70 MiB               
[2020-04-27T06:16:56.896Z] galaxy/python-pygments             2.6.1-2          9.42 MiB               
[2020-04-27T06:16:56.896Z] world/python-pyparsing             2.4.7-1          0.73 MiB               
[2020-04-27T06:16:56.896Z] world/python-setuptools            1:46.1.3-1       1.53 MiB               
[2020-04-27T06:16:56.896Z] world/python-six                   1.14.0-1         0.09 MiB               
[2020-04-27T06:16:56.896Z] galaxy/python-wcwidth              0.1.9-1          0.09 MiB       0.02 MiB
[2020-04-27T06:16:56.896Z] galaxy/python-zipp                 3.1.0-1          0.03 MiB               
[2020-04-27T06:16:56.896Z] community/python2-apipkg           1.5-3            0.03 MiB               
[2020-04-27T06:16:56.896Z] world/python2-appdirs              1.4.3-5          0.08 MiB               
[2020-04-27T06:16:56.896Z] community/python2-atomicwrites     1.3.0-3          0.03 MiB               
[2020-04-27T06:16:56.896Z] world/python2-attrs                19.3.0-4         0.33 MiB               
[2020-04-27T06:16:56.896Z] extra/python2-backports            1.0-2            0.00 MiB               
[2020-04-27T06:16:56.896Z] extra/python2-configparser         4.0.2-1          0.21 MiB               
[2020-04-27T06:16:56.896Z] galaxy/python2-contextlib2         0.6.0.post1-1    0.06 MiB               
[2020-04-27T06:16:56.896Z] community/python2-funcsigs         1.0.2-2          0.09 MiB               
[2020-04-27T06:16:56.896Z] galaxy/python2-importlib-metadata  1.5.1-1          0.20 MiB               
[2020-04-27T06:16:56.896Z] community/python2-iniconfig        1.0.0-4          0.02 MiB               
[2020-04-27T06:16:56.896Z] community/python2-more-itertools   5.0.0-1          0.48 MiB               
[2020-04-27T06:16:56.896Z] world/python2-ordered-set          3.1.1-1          0.05 MiB               
[2020-04-27T06:16:56.896Z] world/python2-packaging            20.3-1           0.19 MiB               
[2020-04-27T06:16:56.896Z] community/python2-pathlib2         2.3.5-1          0.18 MiB               
[2020-04-27T06:16:56.896Z] community/python2-pluggy           0.13.1-1         0.13 MiB               
[2020-04-27T06:16:56.896Z] galaxy/python2-py                  1.8.1-1          0.80 MiB               
[2020-04-27T06:16:56.896Z] world/python2-pyparsing            2.4.7-1          0.79 MiB               
[2020-04-27T06:16:56.896Z] community/python2-scandir          1.10.0-3         0.09 MiB               
[2020-04-27T06:16:56.896Z] world/python2-setuptools           1:45.0.0-1       1.75 MiB               
[2020-04-27T06:16:56.896Z] world/python2-six                  1.14.0-1         0.10 MiB               
[2020-04-27T06:16:56.896Z] galaxy/python2-wcwidth             0.1.9-1          0.10 MiB       0.02 MiB
[2020-04-27T06:16:56.896Z] world/python                       3.8.2-2         80.70 MiB               
[2020-04-27T06:16:56.896Z] galaxy/python-pytest               5.4.1-1          2.69 MiB               
[2020-04-27T06:16:56.896Z] world/python2                      2.7.18-1        75.39 MiB               
[2020-04-27T06:16:56.896Z] community/python2-pytest           4.6.9-1          2.25 MiB               
[2020-04-27T06:16:56.896Z] galaxy/python2-zipp                2.0.0-1          0.02 MiB               
[2020-04-27T06:16:56.896Z] 
[2020-04-27T06:16:56.896Z] Total Download Size:     0.04 MiB
[2020-04-27T06:16:56.896Z] Total Installed Size:  180.75 MiB
[2020-04-27T06:16:56.896Z] 
[2020-04-27T06:16:56.896Z] :: Proceed with installation? [Y/n] 
[2020-04-27T06:16:56.896Z] :: Retrieving packages...
[2020-04-27T06:16:56.896Z] downloading python-wcwidth-0.1.9-1-any.pkg.tar.xz...
[2020-04-27T06:16:56.896Z] downloading python2-wcwidth-0.1.9-1-any.pkg.tar.xz...
[2020-04-27T06:16:56.896Z] checking keyring...
[2020-04-27T06:16:56.896Z] checking package integrity...
[2020-04-27T06:16:58.757Z] loading package files...
[2020-04-27T06:16:59.007Z] checking for file conflicts...
[2020-04-27T06:16:59.007Z] checking available disk space...
[2020-04-27T06:16:59.007Z] :: Processing package changes...
[2020-04-27T06:16:59.007Z] installing libnsl...
[2020-04-27T06:16:59.007Z] installing python...
[2020-04-27T06:17:01.490Z] Optional dependencies for python
[2020-04-27T06:17:01.490Z]     python-setuptools [pending]
[2020-04-27T06:17:01.490Z]     python-pip
[2020-04-27T06:17:01.490Z]     sqlite [installed]
[2020-04-27T06:17:01.490Z]     mpdecimal: for decimal
[2020-04-27T06:17:01.490Z]     xz: for lzma [installed]
[2020-04-27T06:17:01.490Z]     tk: for tkinter
[2020-04-27T06:17:01.490Z] installing python2...
[2020-04-27T06:17:02.832Z] Optional dependencies for python2
[2020-04-27T06:17:02.832Z]     tk: for IDLE
[2020-04-27T06:17:02.832Z]     python2-setuptools [pending]
[2020-04-27T06:17:02.832Z]     python2-pip
[2020-04-27T06:17:02.833Z] installing python-iniconfig...
[2020-04-27T06:17:02.833Z] installing python-apipkg...
[2020-04-27T06:17:02.833Z] installing python-py...
[2020-04-27T06:17:02.833Z] installing python-appdirs...
[2020-04-27T06:17:02.833Z] installing python-pyparsing...
[2020-04-27T06:17:02.833Z] installing python-six...
[2020-04-27T06:17:02.833Z] installing python-packaging...
[2020-04-27T06:17:02.833Z] installing python-ordered-set...
[2020-04-27T06:17:02.833Z] installing python-setuptools...
[2020-04-27T06:17:02.833Z] installing python-zipp...
[2020-04-27T06:17:02.833Z] installing python-importlib-metadata...
[2020-04-27T06:17:02.833Z] installing python-pluggy...
[2020-04-27T06:17:02.833Z] installing python-attrs...
[2020-04-27T06:17:02.833Z] installing python-more-itertools...
[2020-04-27T06:17:02.833Z] installing python-atomicwrites...
[2020-04-27T06:17:02.833Z] installing python-wcwidth...
[2020-04-27T06:17:02.833Z] installing python-pygments...
[2020-04-27T06:17:02.833Z] installing python-pytest...
[2020-04-27T06:17:02.833Z] installing python2-iniconfig...
[2020-04-27T06:17:02.833Z] installing python2-apipkg...
[2020-04-27T06:17:02.833Z] installing python2-py...
[2020-04-27T06:17:03.083Z] installing python2-appdirs...
[2020-04-27T06:17:03.083Z] installing python2-pyparsing...
[2020-04-27T06:17:03.083Z] installing python2-six...
[2020-04-27T06:17:03.083Z] installing python2-packaging...
[2020-04-27T06:17:03.083Z] installing python2-ordered-set...
[2020-04-27T06:17:03.083Z] installing python2-setuptools...
[2020-04-27T06:17:03.083Z] installing python2-more-itertools...
[2020-04-27T06:17:03.083Z] installing python2-zipp...
[2020-04-27T06:17:03.083Z] installing python2-backports...
[2020-04-27T06:17:03.083Z] installing python2-configparser...
[2020-04-27T06:17:03.083Z] installing python2-contextlib2...
[2020-04-27T06:17:03.083Z] installing python2-scandir...
[2020-04-27T06:17:03.083Z] installing python2-pathlib2...
[2020-04-27T06:17:03.083Z] installing python2-importlib-metadata...
[2020-04-27T06:17:03.083Z] installing python2-pluggy...
[2020-04-27T06:17:03.083Z] installing python2-attrs...
[2020-04-27T06:17:03.083Z] installing python2-atomicwrites...
[2020-04-27T06:17:03.083Z] installing python2-wcwidth...
[2020-04-27T06:17:03.083Z] installing python2-funcsigs...
[2020-04-27T06:17:03.083Z] installing python2-pytest...
[2020-04-27T06:17:03.083Z] ==> Retrieving sources...
[2020-04-27T06:17:03.083Z]   -> Found u-msgpack-python-2.6.0.tar.gz
[2020-04-27T06:17:03.083Z] ==> WARNING: Skipping all source file integrity checks.
[2020-04-27T06:17:03.083Z] ==> Extracting sources...
[2020-04-27T06:17:03.333Z]   -> Extracting u-msgpack-python-2.6.0.tar.gz with bsdtar
[2020-04-27T06:17:03.333Z] ==> Starting build()...
[2020-04-27T06:17:03.333Z] running build
[2020-04-27T06:17:03.333Z] running build_py
[2020-04-27T06:17:03.333Z] creating build
[2020-04-27T06:17:03.333Z] creating build/lib
[2020-04-27T06:17:03.333Z] copying umsgpack.py -> build/lib
[2020-04-27T06:17:03.584Z] /usr/lib/python2.7/site-packages/pkg_resources/py2_warn.py:19: UserWarning: ************************************************************
[2020-04-27T06:17:03.584Z] You are running Setuptools on Python 2, which is no longer
[2020-04-27T06:17:03.584Z] supported and
[2020-04-27T06:17:03.584Z] >>> SETUPTOOLS WILL STOP WORKING <<<
[2020-04-27T06:17:03.584Z] in a subsequent release. Please ensure you are installing
[2020-04-27T06:17:03.584Z] Setuptools using pip 9.x or later or pin to `setuptools<45`
[2020-04-27T06:17:03.584Z] in your environment.
[2020-04-27T06:17:03.584Z] If you have done those things and are still encountering
[2020-04-27T06:17:03.584Z] this message, please comment in
[2020-04-27T06:17:03.584Z] https://github.com/pypa/setuptools/issues/1458
[2020-04-27T06:17:03.584Z] about the steps that led to this unsupported combination.
[2020-04-27T06:17:03.584Z] ************************************************************
[2020-04-27T06:17:03.584Z]   sys.version_info < (3,) and warnings.warn("*" * 60 + msg + "*" * 60)
[2020-04-27T06:17:03.584Z] running build
[2020-04-27T06:17:03.584Z] running build_py
[2020-04-27T06:17:03.584Z] ==> Starting check()...
[2020-04-27T06:17:03.834Z] ============================= test session starts ==============================
[2020-04-27T06:17:03.834Z] platform linux -- Python 3.8.2, pytest-5.4.1, py-1.8.1, pluggy-0.13.1
[2020-04-27T06:17:03.834Z] rootdir: /build/python-u-msgpack/src/u-msgpack-python-2.6.0
[2020-04-27T06:17:04.084Z] collected 24 items
[2020-04-27T06:17:04.084Z] 
[2020-04-27T06:17:04.335Z] test_umsgpack.py ........................                                [100%]
[2020-04-27T06:17:04.335Z] 
[2020-04-27T06:17:04.335Z] ============================== 24 passed in 0.39s ==============================
[2020-04-27T06:17:04.585Z] /usr/lib/python2.7/site-packages/pkg_resources/py2_warn.py:19: UserWarning: ************************************************************
[2020-04-27T06:17:04.585Z] You are running Setuptools on Python 2, which is no longer
[2020-04-27T06:17:04.585Z] supported and
[2020-04-27T06:17:04.585Z] >>> SETUPTOOLS WILL STOP WORKING <<<
[2020-04-27T06:17:04.585Z] in a subsequent release. Please ensure you are installing
[2020-04-27T06:17:04.585Z] Setuptools using pip 9.x or later or pin to `setuptools<45`
[2020-04-27T06:17:04.585Z] in your environment.
[2020-04-27T06:17:04.585Z] If you have done those things and are still encountering
[2020-04-27T06:17:04.585Z] this message, please comment in
[2020-04-27T06:17:04.585Z] https://github.com/pypa/setuptools/issues/1458
[2020-04-27T06:17:04.585Z] about the steps that led to this unsupported combination.
[2020-04-27T06:17:04.585Z] ************************************************************
[2020-04-27T06:17:04.585Z]   sys.version_info < (3,) and warnings.warn("*" * 60 + msg + "*" * 60)
[2020-04-27T06:17:04.585Z] Traceback (most recent call last):
[2020-04-27T06:17:04.585Z]   File "/usr/bin/pytest2", line 6, in <module>
[2020-04-27T06:17:04.585Z]     from pkg_resources import load_entry_point
[2020-04-27T06:17:04.585Z]   File "/usr/lib/python2.7/site-packages/pkg_resources/__init__.py", line 3252, in <module>
[2020-04-27T06:17:04.585Z]     @_call_aside
[2020-04-27T06:17:04.585Z]   File "/usr/lib/python2.7/site-packages/pkg_resources/__init__.py", line 3236, in _call_aside
[2020-04-27T06:17:04.585Z]     f(*args, **kwargs)
[2020-04-27T06:17:04.585Z]   File "/usr/lib/python2.7/site-packages/pkg_resources/__init__.py", line 3265, in _initialize_master_working_set
[2020-04-27T06:17:04.585Z]     working_set = WorkingSet._build_master()
[2020-04-27T06:17:04.585Z]   File "/usr/lib/python2.7/site-packages/pkg_resources/__init__.py", line 586, in _build_master
[2020-04-27T06:17:04.585Z]     return cls._build_from_requirements(__requires__)
[2020-04-27T06:17:04.585Z]   File "/usr/lib/python2.7/site-packages/pkg_resources/__init__.py", line 599, in _build_from_requirements
[2020-04-27T06:17:04.585Z]     dists = ws.resolve(reqs, Environment())
[2020-04-27T06:17:04.585Z]   File "/usr/lib/python2.7/site-packages/pkg_resources/__init__.py", line 787, in resolve
[2020-04-27T06:17:04.585Z]     raise DistributionNotFound(req, requirers)
[2020-04-27T06:17:04.585Z] pkg_resources.DistributionNotFound: The 'zipp>=0.5' distribution was not found and is required by importlib-metadata
[2020-04-27T06:17:04.585Z] ==> ERROR: A failure occurred in check().
[2020-04-27T06:17:04.585Z]     Aborting...
[2020-04-27T06:17:05.496Z] ==> ERROR: Build failed, check /build/buildpkg/default-x86_64/jenkins/build
[Pipeline] }
[Pipeline] // dir
Post stage
[Pipeline] emailext
[2020-04-27T06:17:05.603Z] Sending email to: artix-build-failures at artixlinux.org


More information about the artix-build-failures mailing list