[artix-build-failures] [galaxy] Failure: python-distro

jenkins at artixlinux.org jenkins at artixlinux.org
Sun Apr 26 09:12:21 CEST 2020


   Failure

   Build: repos/community-any

   Packages:

   [python-distro-1.5.0-1-any.pkg.tar.xz,
   python2-distro-1.5.0-1-any.pkg.tar.xz]

   authorName: alium

   authorEmail: alium at artixlinux.org

   [1]https://orion.artixlinux.org/job/packagesPython/job/python-distro/jo
   b/master/6/

References

   1. https://orion.artixlinux.org/job/packagesPython/job/python-distro/job/master/6/
-------------- next part --------------
Push event to branch master
Querying the current revision of branch master...
Current revision of branch master is 70b49a7410415c68f00ab943c1c9a965a6cec703
Obtained Jenkinsfile from 70b49a7410415c68f00ab943c1c9a965a6cec703
Running in Durability level: PERFORMANCE_OPTIMIZED
Loading library artix-ci at master
Attempting to resolve master from remote references...
 > git --version # timeout=10
 > git ls-remote -- https://gitea.artixlinux.org/artix/pipeline-libs.git # timeout=10
Found match: refs/heads/master revision 77f77ff85eedb6eb60b64faf8c328ab86dbb479c
Warning: CredentialId "gitea-ci" could not be found.
Cloning the remote Git repository
Cloning with configured refspecs honoured and without tags
Cloning repository https://gitea.artixlinux.org/artix/pipeline-libs.git
 > git init /build/jenkins/workspace/kagesPython_python-distro_master at libs/artix-ci # timeout=10
Fetching upstream changes from https://gitea.artixlinux.org/artix/pipeline-libs.git
 > git --version # timeout=10
 > git fetch --no-tags --force --progress -- https://gitea.artixlinux.org/artix/pipeline-libs.git +refs/heads/master:refs/remotes/origin/master # timeout=10
 > git config remote.origin.url https://gitea.artixlinux.org/artix/pipeline-libs.git # timeout=10
 > git config --add remote.origin.fetch +refs/heads/master:refs/remotes/origin/master # timeout=10
 > git config remote.origin.url https://gitea.artixlinux.org/artix/pipeline-libs.git # timeout=10
Fetching without tags
Fetching upstream changes from https://gitea.artixlinux.org/artix/pipeline-libs.git
 > git fetch --no-tags --force --progress -- https://gitea.artixlinux.org/artix/pipeline-libs.git +refs/heads/master:refs/remotes/origin/master # timeout=10
Checking out Revision 77f77ff85eedb6eb60b64faf8c328ab86dbb479c (master)
 > git config core.sparsecheckout # timeout=10
 > git checkout -f 77f77ff85eedb6eb60b64faf8c328ab86dbb479c # timeout=10
Commit message: "Notify: remove fail condition"
[Gitea] Notifying branch build status: PENDING Build started...
[Gitea] Notified
[Pipeline] Start of Pipeline
[Pipeline] node
Running on Jenkins in /build/jenkins/workspace/kagesPython_python-distro_master
[Pipeline] {
[Pipeline] timestamps
[Pipeline] {
[Pipeline] stage
[Pipeline] { (Prepare)
[Pipeline] checkout
[2020-04-26T07:11:50.483Z] Warning: CredentialId "jenkins-ci" could not be found.
[2020-04-26T07:11:50.483Z] Cloning the remote Git repository
[2020-04-26T07:11:50.484Z] Cloning with configured refspecs honoured and without tags
[2020-04-26T07:11:50.484Z] Cloning repository https://237b7412742b4068af4173944de150f12959f4d3@gitea.artixlinux.org/packagesPython/python-distro.git
[2020-04-26T07:11:50.484Z]  > git init /build/jenkins/workspace/kagesPython_python-distro_master # timeout=10
[2020-04-26T07:11:50.495Z] Fetching upstream changes from https://237b7412742b4068af4173944de150f12959f4d3@gitea.artixlinux.org/packagesPython/python-distro.git
[2020-04-26T07:11:50.495Z]  > git --version # timeout=10
[2020-04-26T07:11:50.500Z]  > git fetch --no-tags --force --progress -- https://237b7412742b4068af4173944de150f12959f4d3@gitea.artixlinux.org/packagesPython/python-distro.git +refs/heads/master:refs/remotes/origin/master # timeout=10
[2020-04-26T07:11:50.638Z]  > git config remote.origin.url https://237b7412742b4068af4173944de150f12959f4d3@gitea.artixlinux.org/packagesPython/python-distro.git # timeout=10
[2020-04-26T07:11:50.643Z]  > git config --add remote.origin.fetch +refs/heads/master:refs/remotes/origin/master # timeout=10
[2020-04-26T07:11:50.648Z]  > git config remote.origin.url https://237b7412742b4068af4173944de150f12959f4d3@gitea.artixlinux.org/packagesPython/python-distro.git # timeout=10
[2020-04-26T07:11:50.652Z] Cleaning workspace
[2020-04-26T07:11:50.652Z]  > git rev-parse --verify HEAD # timeout=10
[2020-04-26T07:11:50.657Z] No valid HEAD. Skipping the resetting
[2020-04-26T07:11:50.657Z]  > git clean -fdx # timeout=10
[2020-04-26T07:11:50.662Z] Fetching without tags
[2020-04-26T07:11:50.662Z] Fetching upstream changes from https://237b7412742b4068af4173944de150f12959f4d3@gitea.artixlinux.org/packagesPython/python-distro.git
[2020-04-26T07:11:50.662Z]  > git fetch --no-tags --force --progress -- https://237b7412742b4068af4173944de150f12959f4d3@gitea.artixlinux.org/packagesPython/python-distro.git +refs/heads/master:refs/remotes/origin/master # timeout=10
[2020-04-26T07:11:50.755Z] Checking out Revision 70b49a7410415c68f00ab943c1c9a965a6cec703 (master)
[2020-04-26T07:11:50.755Z]  > git config core.sparsecheckout # timeout=10
[2020-04-26T07:11:50.760Z]  > git checkout -f 70b49a7410415c68f00ab943c1c9a965a6cec703 # timeout=10
[2020-04-26T07:11:50.769Z] Commit message: "[trunk] -> [community] 'python-distro-1.5.0-1' add"
[2020-04-26T07:11:50.769Z]  > git rev-list --no-walk 3c1c695c61c04e113f9615b2ecfdfe2dfc4862c8 # timeout=10
[2020-04-26T07:11:50.786Z] [Gitea] Notifying branch build status: PENDING Build started...
[2020-04-26T07:11:50.921Z] [Gitea] Notified
[Pipeline] libraryResource
[Pipeline] readYaml
[Pipeline] sh
[2020-04-26T07:11:51.197Z] + git rev-parse @
[Pipeline] sh
[2020-04-26T07:11:51.454Z] + git show -s --format=%an 70b49a7410415c68f00ab943c1c9a965a6cec703
[Pipeline] sh
[2020-04-26T07:11:51.711Z] + git show -s --format=%ae 70b49a7410415c68f00ab943c1c9a965a6cec703
[Pipeline] sh
[2020-04-26T07:11:51.968Z] + git show --pretty=format: --name-status 70b49a7410415c68f00ab943c1c9a965a6cec703
[Pipeline] fileExists
[Pipeline] sh
[2020-04-26T07:11:52.241Z] + pkg2yaml repos/community-any
[Pipeline] readYaml
[Pipeline] }
[Pipeline] // stage
[Pipeline] stage
[Pipeline] { (Build)
[Pipeline] echo
[2020-04-26T07:11:52.328Z] isRebuild: false
[Pipeline] dir
[2020-04-26T07:11:52.334Z] Running in /build/jenkins/workspace/kagesPython_python-distro_master/repos/community-any
[Pipeline] {
[Pipeline] sh
[2020-04-26T07:11:52.596Z] + buildpkg-galaxy
[2020-04-26T07:11:55.825Z] :: Synchronizing package databases...
[2020-04-26T07:11:55.825Z]  system is up to date
[2020-04-26T07:11:55.825Z]  world is up to date
[2020-04-26T07:11:55.825Z]  galaxy is up to date
[2020-04-26T07:11:55.825Z] downloading extra.db...
[2020-04-26T07:11:55.825Z]  community is up to date
[2020-04-26T07:11:55.825Z] :: Starting full system upgrade...
[2020-04-26T07:11:55.825Z]  there is nothing to do
[2020-04-26T07:11:56.736Z] ==> Building in chroot for [default] (x86_64)...
[2020-04-26T07:11:56.986Z] ==> Synchronizing chroot copy [/build/buildpkg/default-x86_64/root] -> [jenkins]...done
[2020-04-26T07:11:58.329Z] ==> Making package: python-distro 1.5.0-1 (Sun Apr 26 09:11:58 2020)
[2020-04-26T07:11:58.329Z] ==> Retrieving sources...
[2020-04-26T07:11:58.579Z]   -> Downloading python-distro-1.5.0.tar.gz...
[2020-04-26T07:11:58.579Z]   % Total    % Received % Xferd  Average Speed   Time    Time     Time  Current
[2020-04-26T07:11:58.579Z]                                  Dload  Upload   Total   Spent    Left  Speed
[2020-04-26T07:11:58.579Z] 
  0     0    0     0    0     0      0      0 --:--:-- --:--:-- --:--:--     0
100   120  100   120    0     0    504      0 --:--:-- --:--:-- --:--:--   504
[2020-04-26T07:11:59.380Z] 
  0     0    0     0    0     0      0      0 --:--:-- --:--:-- --:--:--     0
100 51022    0 51022    0     0  63224      0 --:--:-- --:--:-- --:--:--  108k
[2020-04-26T07:11:59.380Z] ==> Validating source files with sha512sums...
[2020-04-26T07:11:59.380Z]     python-distro-1.5.0.tar.gz ... Passed
[2020-04-26T07:11:59.380Z] ==> Validating source files with b2sums...
[2020-04-26T07:11:59.380Z]     python-distro-1.5.0.tar.gz ... Passed
[2020-04-26T07:12:05.861Z] ==> Making package: python-distro 1.5.0-1 (Sun 26 Apr 2020 09:12:04 AM CEST)
[2020-04-26T07:12:05.861Z] ==> Checking runtime dependencies...
[2020-04-26T07:12:05.861Z] ==> Checking buildtime dependencies...
[2020-04-26T07:12:05.861Z] ==> Installing missing dependencies...
[2020-04-26T07:12:05.861Z] resolving dependencies...
[2020-04-26T07:12:05.861Z] looking for conflicting packages...
[2020-04-26T07:12:05.861Z] 
[2020-04-26T07:12:05.861Z] Package (63)                                 New Version    Net Change
[2020-04-26T07:12:05.861Z] 
[2020-04-26T07:12:05.861Z] system/libnsl                                1.2.0-2          0.19 MiB
[2020-04-26T07:12:05.861Z] world/python                                 3.8.2-2         80.70 MiB
[2020-04-26T07:12:05.861Z] galaxy/python-apipkg                         1.5-3            0.02 MiB
[2020-04-26T07:12:05.861Z] world/python-appdirs                         1.4.3-5          0.07 MiB
[2020-04-26T07:12:05.861Z] galaxy/python-atomicwrites                   1.3.0-3          0.03 MiB
[2020-04-26T07:12:05.861Z] world/python-attrs                           19.3.0-4         0.30 MiB
[2020-04-26T07:12:05.861Z] galaxy/python-babel                          2.8.0-4         26.42 MiB
[2020-04-26T07:12:05.861Z] world/python-chardet                         3.0.4-4          1.12 MiB
[2020-04-26T07:12:05.861Z] galaxy/python-docutils                       0.16-1           4.22 MiB
[2020-04-26T07:12:05.861Z] world/python-idna                            2.9-1            0.67 MiB
[2020-04-26T07:12:05.861Z] galaxy/python-imagesize                      1.2.0-1          0.02 MiB
[2020-04-26T07:12:05.861Z] galaxy/python-importlib-metadata             1.5.1-1          0.18 MiB
[2020-04-26T07:12:05.861Z] galaxy/python-iniconfig                      1.0.0-4          0.02 MiB
[2020-04-26T07:12:05.861Z] galaxy/python-jinja                          2.11.2-1         1.18 MiB
[2020-04-26T07:12:05.861Z] world/python-markupsafe                      1.1.1-3          0.08 MiB
[2020-04-26T07:12:05.861Z] galaxy/python-more-itertools                 8.2.0-1          0.25 MiB
[2020-04-26T07:12:05.861Z] world/python-ordered-set                     3.1.1-1          0.05 MiB
[2020-04-26T07:12:05.861Z] world/python-packaging                       20.3-1           0.17 MiB
[2020-04-26T07:12:05.861Z] galaxy/python-pluggy                         0.13.1-1         0.12 MiB
[2020-04-26T07:12:05.861Z] galaxy/python-py                             1.8.1-1          0.70 MiB
[2020-04-26T07:12:05.861Z] galaxy/python-pygments                       2.6.1-2          9.42 MiB
[2020-04-26T07:12:05.861Z] world/python-pyparsing                       2.4.7-1          0.73 MiB
[2020-04-26T07:12:05.861Z] galaxy/python-pytz                           2019.3-3         0.95 MiB
[2020-04-26T07:12:05.861Z] world/python-requests                        2.23.0-1         0.44 MiB
[2020-04-26T07:12:05.861Z] world/python-six                             1.14.0-1         0.09 MiB
[2020-04-26T07:12:05.861Z] galaxy/python-snowballstemmer                2.0.0-3          1.44 MiB
[2020-04-26T07:12:05.861Z] galaxy/python-sphinx-alabaster-theme         0.7.12-3         0.04 MiB
[2020-04-26T07:12:05.861Z] galaxy/python-sphinxcontrib-applehelp        1.0.2-1          0.24 MiB
[2020-04-26T07:12:05.861Z] galaxy/python-sphinxcontrib-devhelp          1.0.2-1          0.12 MiB
[2020-04-26T07:12:05.861Z] galaxy/python-sphinxcontrib-htmlhelp         1.0.3-1          0.16 MiB
[2020-04-26T07:12:05.861Z] galaxy/python-sphinxcontrib-jsmath           1.0.1-4          0.01 MiB
[2020-04-26T07:12:05.861Z] galaxy/python-sphinxcontrib-qthelp           1.0.3-1          0.15 MiB
[2020-04-26T07:12:05.861Z] galaxy/python-sphinxcontrib-serializinghtml  1.1.4-1          0.12 MiB
[2020-04-26T07:12:05.861Z] world/python-urllib3                         1.25.9-1         0.64 MiB
[2020-04-26T07:12:05.861Z] galaxy/python-wcwidth                        0.1.8-1          0.08 MiB
[2020-04-26T07:12:05.861Z] galaxy/python-zipp                           3.1.0-1          0.03 MiB
[2020-04-26T07:12:05.861Z] world/python2                                2.7.17-3        75.37 MiB
[2020-04-26T07:12:05.861Z] community/python2-apipkg                     1.5-3            0.03 MiB
[2020-04-26T07:12:05.861Z] world/python2-appdirs                        1.4.3-5          0.08 MiB
[2020-04-26T07:12:05.861Z] community/python2-atomicwrites               1.3.0-3          0.03 MiB
[2020-04-26T07:12:05.861Z] world/python2-attrs                          19.3.0-4         0.33 MiB
[2020-04-26T07:12:05.861Z] extra/python2-backports                      1.0-2            0.00 MiB
[2020-04-26T07:12:05.861Z] extra/python2-configparser                   4.0.2-1          0.21 MiB
[2020-04-26T07:12:05.861Z] galaxy/python2-contextlib2                   0.6.0.post1-1    0.06 MiB
[2020-04-26T07:12:05.861Z] community/python2-funcsigs                   1.0.2-2          0.09 MiB
[2020-04-26T07:12:05.861Z] galaxy/python2-importlib-metadata            1.5.1-1          0.20 MiB
[2020-04-26T07:12:05.861Z] community/python2-iniconfig                  1.0.0-4          0.02 MiB
[2020-04-26T07:12:05.861Z] community/python2-more-itertools             5.0.0-1          0.48 MiB
[2020-04-26T07:12:05.861Z] world/python2-ordered-set                    3.1.1-1          0.05 MiB
[2020-04-26T07:12:05.861Z] world/python2-packaging                      20.3-1           0.19 MiB
[2020-04-26T07:12:05.861Z] community/python2-pathlib2                   2.3.5-1          0.18 MiB
[2020-04-26T07:12:05.861Z] community/python2-pluggy                     0.13.1-1         0.13 MiB
[2020-04-26T07:12:05.861Z] galaxy/python2-py                            1.8.1-1          0.80 MiB
[2020-04-26T07:12:05.861Z] world/python2-pyparsing                      2.4.7-1          0.79 MiB
[2020-04-26T07:12:05.861Z] community/python2-scandir                    1.10.0-3         0.09 MiB
[2020-04-26T07:12:05.861Z] world/python2-six                            1.14.0-1         0.10 MiB
[2020-04-26T07:12:05.861Z] galaxy/python2-wcwidth                       0.1.8-1          0.09 MiB
[2020-04-26T07:12:05.861Z] galaxy/python2-zipp                          2.0.0-1          0.02 MiB
[2020-04-26T07:12:05.861Z] galaxy/python-pytest                         5.4.1-1          2.69 MiB
[2020-04-26T07:12:05.861Z] world/python-setuptools                      1:46.1.3-1       1.53 MiB
[2020-04-26T07:12:05.861Z] galaxy/python-sphinx                         3.0.2-1         14.81 MiB
[2020-04-26T07:12:05.861Z] community/python2-pytest                     4.6.9-1          2.25 MiB
[2020-04-26T07:12:05.861Z] world/python2-setuptools                     1:45.0.0-1       1.75 MiB
[2020-04-26T07:12:05.861Z] 
[2020-04-26T07:12:05.861Z] Total Installed Size:  233.55 MiB
[2020-04-26T07:12:05.861Z] 
[2020-04-26T07:12:05.861Z] :: Proceed with installation? [Y/n] 
[2020-04-26T07:12:05.861Z] checking keyring...
[2020-04-26T07:12:05.861Z] checking package integrity...
[2020-04-26T07:12:09.089Z] loading package files...
[2020-04-26T07:12:09.089Z] checking for file conflicts...
[2020-04-26T07:12:09.089Z] checking available disk space...
[2020-04-26T07:12:09.089Z] :: Processing package changes...
[2020-04-26T07:12:09.089Z] installing libnsl...
[2020-04-26T07:12:09.089Z] installing python...
[2020-04-26T07:12:11.571Z] Optional dependencies for python
[2020-04-26T07:12:11.571Z]     python-setuptools [pending]
[2020-04-26T07:12:11.571Z]     python-pip
[2020-04-26T07:12:11.571Z]     sqlite [installed]
[2020-04-26T07:12:11.571Z]     mpdecimal: for decimal
[2020-04-26T07:12:11.571Z]     xz: for lzma [installed]
[2020-04-26T07:12:11.571Z]     tk: for tkinter
[2020-04-26T07:12:11.571Z] installing python-appdirs...
[2020-04-26T07:12:11.571Z] installing python-pyparsing...
[2020-04-26T07:12:11.571Z] installing python-six...
[2020-04-26T07:12:11.571Z] installing python-packaging...
[2020-04-26T07:12:11.571Z] installing python-ordered-set...
[2020-04-26T07:12:11.571Z] installing python-setuptools...
[2020-04-26T07:12:11.571Z] installing python-pytz...
[2020-04-26T07:12:11.571Z] installing python-babel...
[2020-04-26T07:12:11.822Z] installing python-docutils...
[2020-04-26T07:12:12.072Z] installing python-imagesize...
[2020-04-26T07:12:12.072Z] installing python-markupsafe...
[2020-04-26T07:12:12.072Z] installing python-jinja...
[2020-04-26T07:12:12.072Z] Optional dependencies for python-jinja
[2020-04-26T07:12:12.072Z]     python-babel: for i18n support [installed]
[2020-04-26T07:12:12.072Z] installing python-pygments...
[2020-04-26T07:12:12.072Z] installing python-urllib3...
[2020-04-26T07:12:12.322Z] Optional dependencies for python-urllib3
[2020-04-26T07:12:12.322Z]     python-pysocks: SOCKS support
[2020-04-26T07:12:12.322Z]     python-brotli: Brotli support
[2020-04-26T07:12:12.322Z]     python-pyopenssl: security support
[2020-04-26T07:12:12.322Z] installing python-chardet...
[2020-04-26T07:12:12.322Z] installing python-idna...
[2020-04-26T07:12:12.322Z] installing python-requests...
[2020-04-26T07:12:12.322Z] Optional dependencies for python-requests
[2020-04-26T07:12:12.322Z]     python-pysocks: SOCKS proxy support
[2020-04-26T07:12:12.322Z] installing python-snowballstemmer...
[2020-04-26T07:12:12.322Z] Optional dependencies for python-snowballstemmer
[2020-04-26T07:12:12.322Z]     python-pystemmer: for improved performance
[2020-04-26T07:12:12.323Z] installing python-sphinx-alabaster-theme...
[2020-04-26T07:12:12.323Z] installing python-sphinxcontrib-applehelp...
[2020-04-26T07:12:12.323Z] installing python-sphinxcontrib-devhelp...
[2020-04-26T07:12:12.323Z] installing python-sphinxcontrib-htmlhelp...
[2020-04-26T07:12:12.323Z] installing python-sphinxcontrib-jsmath...
[2020-04-26T07:12:12.323Z] installing python-sphinxcontrib-qthelp...
[2020-04-26T07:12:12.323Z] installing python-sphinxcontrib-serializinghtml...
[2020-04-26T07:12:12.323Z] installing python-sphinx...
[2020-04-26T07:12:12.573Z] Optional dependencies for python-sphinx
[2020-04-26T07:12:12.573Z]     imagemagick: for ext.imgconverter
[2020-04-26T07:12:12.573Z]     texlive-latexextra: for generation of PDF documentation
[2020-04-26T07:12:12.573Z] installing python2...
[2020-04-26T07:12:13.916Z] Optional dependencies for python2
[2020-04-26T07:12:13.916Z]     tk: for IDLE
[2020-04-26T07:12:13.916Z]     python2-setuptools [pending]
[2020-04-26T07:12:13.916Z]     python2-pip
[2020-04-26T07:12:13.916Z] installing python2-appdirs...
[2020-04-26T07:12:13.916Z] installing python2-pyparsing...
[2020-04-26T07:12:13.916Z] installing python2-six...
[2020-04-26T07:12:13.916Z] installing python2-packaging...
[2020-04-26T07:12:13.916Z] installing python2-ordered-set...
[2020-04-26T07:12:13.916Z] installing python2-setuptools...
[2020-04-26T07:12:13.916Z] installing python-iniconfig...
[2020-04-26T07:12:13.916Z] installing python-apipkg...
[2020-04-26T07:12:13.916Z] installing python-py...
[2020-04-26T07:12:13.916Z] installing python-zipp...
[2020-04-26T07:12:13.916Z] installing python-importlib-metadata...
[2020-04-26T07:12:13.916Z] installing python-pluggy...
[2020-04-26T07:12:13.916Z] installing python-attrs...
[2020-04-26T07:12:13.916Z] installing python-more-itertools...
[2020-04-26T07:12:13.916Z] installing python-atomicwrites...
[2020-04-26T07:12:13.916Z] installing python-wcwidth...
[2020-04-26T07:12:13.916Z] installing python-pytest...
[2020-04-26T07:12:13.916Z] installing python2-iniconfig...
[2020-04-26T07:12:13.916Z] installing python2-apipkg...
[2020-04-26T07:12:13.916Z] installing python2-py...
[2020-04-26T07:12:13.916Z] installing python2-more-itertools...
[2020-04-26T07:12:13.916Z] installing python2-zipp...
[2020-04-26T07:12:13.916Z] installing python2-backports...
[2020-04-26T07:12:13.916Z] installing python2-configparser...
[2020-04-26T07:12:13.916Z] installing python2-contextlib2...
[2020-04-26T07:12:13.916Z] installing python2-scandir...
[2020-04-26T07:12:13.916Z] installing python2-pathlib2...
[2020-04-26T07:12:13.916Z] installing python2-importlib-metadata...
[2020-04-26T07:12:13.916Z] installing python2-pluggy...
[2020-04-26T07:12:13.916Z] installing python2-attrs...
[2020-04-26T07:12:13.916Z] installing python2-atomicwrites...
[2020-04-26T07:12:13.916Z] installing python2-wcwidth...
[2020-04-26T07:12:13.916Z] installing python2-funcsigs...
[2020-04-26T07:12:13.916Z] installing python2-pytest...
[2020-04-26T07:12:14.167Z] ==> Retrieving sources...
[2020-04-26T07:12:14.167Z]   -> Found python-distro-1.5.0.tar.gz
[2020-04-26T07:12:14.167Z] ==> WARNING: Skipping all source file integrity checks.
[2020-04-26T07:12:14.167Z] ==> Extracting sources...
[2020-04-26T07:12:14.167Z]   -> Extracting python-distro-1.5.0.tar.gz with bsdtar
[2020-04-26T07:12:14.167Z] ==> Starting prepare()...
[2020-04-26T07:12:14.167Z] ==> Starting build()...
[2020-04-26T07:12:14.417Z] running build
[2020-04-26T07:12:14.417Z] running build_py
[2020-04-26T07:12:14.417Z] creating build
[2020-04-26T07:12:14.417Z] creating build/lib
[2020-04-26T07:12:14.417Z] copying distro.py -> build/lib
[2020-04-26T07:12:14.417Z] sphinx-build -b man -d build_docs/doctrees -c docs -D latex_paper_size=a4 -v . build_docs/man
[2020-04-26T07:12:14.968Z] Running Sphinx v3.0.2
[2020-04-26T07:12:14.968Z] making output directory... done
[2020-04-26T07:12:14.968Z] WARNING: unknown config value 'latex_paper_size' in override, ignoring
[2020-04-26T07:12:14.968Z] WARNING: html_extra_path entry 'html_extra' does not exist
[2020-04-26T07:12:14.968Z] WARNING: html_static_path entry 'html_static' does not exist
[2020-04-26T07:12:14.968Z] loading intersphinx inventory from https://docs.python.org/3.5/objects.inv...
[2020-04-26T07:12:15.218Z] building [mo]: targets for 0 po files that are out of date
[2020-04-26T07:12:15.218Z] building [man]: all manpages
[2020-04-26T07:12:15.218Z] updating environment: [new config] 1 added, 0 changed, 0 removed
[2020-04-26T07:12:15.218Z] reading sources... [100%] docs/index
[2020-04-26T07:12:15.769Z] 
[2020-04-26T07:12:15.769Z] /build/python-distro/src/distro-1.5.0/docs/index.rst:23: WARNING: Inline emphasis start-string without end-string.
[2020-04-26T07:12:15.769Z] /build/python-distro/src/distro-1.5.0/docs/index.rst:57: WARNING: Unknown target name: "uname command output".
[2020-04-26T07:12:15.769Z] looking for now-outdated files... none found
[2020-04-26T07:12:15.769Z] pickling environment... done
[2020-04-26T07:12:15.769Z] checking consistency... done
[2020-04-26T07:12:15.769Z] writing... ld.1 { } done
[2020-04-26T07:12:15.769Z] build succeeded, 5 warnings.
[2020-04-26T07:12:15.769Z] 
[2020-04-26T07:12:15.769Z] The manual pages are in build_docs/man.
[2020-04-26T07:12:16.019Z] man done; the manual pages are in build_docs/man.
[2020-04-26T07:12:16.019Z] /usr/lib/python2.7/site-packages/pkg_resources/py2_warn.py:19: UserWarning: ************************************************************
[2020-04-26T07:12:16.019Z] You are running Setuptools on Python 2, which is no longer
[2020-04-26T07:12:16.019Z] supported and
[2020-04-26T07:12:16.019Z] >>> SETUPTOOLS WILL STOP WORKING <<<
[2020-04-26T07:12:16.019Z] in a subsequent release. Please ensure you are installing
[2020-04-26T07:12:16.019Z] Setuptools using pip 9.x or later or pin to `setuptools<45`
[2020-04-26T07:12:16.019Z] in your environment.
[2020-04-26T07:12:16.019Z] If you have done those things and are still encountering
[2020-04-26T07:12:16.019Z] this message, please comment in
[2020-04-26T07:12:16.019Z] https://github.com/pypa/setuptools/issues/1458
[2020-04-26T07:12:16.019Z] about the steps that led to this unsupported combination.
[2020-04-26T07:12:16.019Z] ************************************************************
[2020-04-26T07:12:16.019Z]   sys.version_info < (3,) and warnings.warn("*" * 60 + msg + "*" * 60)
[2020-04-26T07:12:16.019Z] running build
[2020-04-26T07:12:16.019Z] running build_py
[2020-04-26T07:12:16.019Z] creating build
[2020-04-26T07:12:16.019Z] creating build/lib
[2020-04-26T07:12:16.019Z] copying distro.py -> build/lib
[2020-04-26T07:12:16.019Z] sphinx-build -b man -d build_docs/doctrees -c docs -D latex_paper_size=a4 -v . build_docs/man
[2020-04-26T07:12:16.570Z] Running Sphinx v3.0.2
[2020-04-26T07:12:16.570Z] making output directory... done
[2020-04-26T07:12:16.570Z] WARNING: unknown config value 'latex_paper_size' in override, ignoring
[2020-04-26T07:12:16.570Z] WARNING: html_extra_path entry 'html_extra' does not exist
[2020-04-26T07:12:16.570Z] WARNING: html_static_path entry 'html_static' does not exist
[2020-04-26T07:12:16.570Z] loading intersphinx inventory from https://docs.python.org/3.5/objects.inv...
[2020-04-26T07:12:16.820Z] building [mo]: targets for 0 po files that are out of date
[2020-04-26T07:12:16.820Z] building [man]: all manpages
[2020-04-26T07:12:16.820Z] updating environment: [new config] 1 added, 0 changed, 0 removed
[2020-04-26T07:12:16.820Z] reading sources... [100%] docs/index
[2020-04-26T07:12:17.370Z] 
[2020-04-26T07:12:17.370Z] /build/python-distro/src/distro-1.5.0-py2/docs/index.rst:23: WARNING: Inline emphasis start-string without end-string.
[2020-04-26T07:12:17.370Z] /build/python-distro/src/distro-1.5.0-py2/docs/index.rst:57: WARNING: Unknown target name: "uname command output".
[2020-04-26T07:12:17.370Z] looking for now-outdated files... none found
[2020-04-26T07:12:17.370Z] pickling environment... done
[2020-04-26T07:12:17.370Z] checking consistency... done
[2020-04-26T07:12:17.370Z] writing... ld.1 { } done
[2020-04-26T07:12:17.370Z] build succeeded, 5 warnings.
[2020-04-26T07:12:17.370Z] 
[2020-04-26T07:12:17.370Z] The manual pages are in build_docs/man.
[2020-04-26T07:12:17.621Z] man done; the manual pages are in build_docs/man.
[2020-04-26T07:12:17.621Z] ==> Starting check()...
[2020-04-26T07:12:17.871Z] ============================= test session starts ==============================
[2020-04-26T07:12:17.871Z] platform linux -- Python 3.8.2, pytest-5.4.1, py-1.8.1, pluggy-0.13.1
[2020-04-26T07:12:17.871Z] rootdir: /build/python-distro/src/distro-1.5.0
[2020-04-26T07:12:18.121Z] collected 175 items
[2020-04-26T07:12:18.121Z] 
[2020-04-26T07:12:18.872Z] tests/test_distro.py ................................................... [ 29%]
[2020-04-26T07:12:19.623Z] ........................................................................ [ 70%]
[2020-04-26T07:12:20.424Z] ....................................................                     [100%]
[2020-04-26T07:12:20.424Z] 
[2020-04-26T07:12:20.424Z] ============================= 175 passed in 2.47s ==============================
[2020-04-26T07:12:20.424Z] /usr/lib/python2.7/site-packages/pkg_resources/py2_warn.py:19: UserWarning: ************************************************************
[2020-04-26T07:12:20.424Z] You are running Setuptools on Python 2, which is no longer
[2020-04-26T07:12:20.424Z] supported and
[2020-04-26T07:12:20.424Z] >>> SETUPTOOLS WILL STOP WORKING <<<
[2020-04-26T07:12:20.424Z] in a subsequent release. Please ensure you are installing
[2020-04-26T07:12:20.424Z] Setuptools using pip 9.x or later or pin to `setuptools<45`
[2020-04-26T07:12:20.424Z] in your environment.
[2020-04-26T07:12:20.424Z] If you have done those things and are still encountering
[2020-04-26T07:12:20.424Z] this message, please comment in
[2020-04-26T07:12:20.424Z] https://github.com/pypa/setuptools/issues/1458
[2020-04-26T07:12:20.424Z] about the steps that led to this unsupported combination.
[2020-04-26T07:12:20.424Z] ************************************************************
[2020-04-26T07:12:20.424Z]   sys.version_info < (3,) and warnings.warn("*" * 60 + msg + "*" * 60)
[2020-04-26T07:12:20.674Z] Traceback (most recent call last):
[2020-04-26T07:12:20.674Z]   File "/usr/bin/py.test2", line 6, in <module>
[2020-04-26T07:12:20.674Z]     from pkg_resources import load_entry_point
[2020-04-26T07:12:20.674Z]   File "/usr/lib/python2.7/site-packages/pkg_resources/__init__.py", line 3252, in <module>
[2020-04-26T07:12:20.674Z]     @_call_aside
[2020-04-26T07:12:20.674Z]   File "/usr/lib/python2.7/site-packages/pkg_resources/__init__.py", line 3236, in _call_aside
[2020-04-26T07:12:20.674Z]     f(*args, **kwargs)
[2020-04-26T07:12:20.674Z]   File "/usr/lib/python2.7/site-packages/pkg_resources/__init__.py", line 3265, in _initialize_master_working_set
[2020-04-26T07:12:20.674Z]     working_set = WorkingSet._build_master()
[2020-04-26T07:12:20.674Z]   File "/usr/lib/python2.7/site-packages/pkg_resources/__init__.py", line 586, in _build_master
[2020-04-26T07:12:20.674Z]     return cls._build_from_requirements(__requires__)
[2020-04-26T07:12:20.674Z]   File "/usr/lib/python2.7/site-packages/pkg_resources/__init__.py", line 599, in _build_from_requirements
[2020-04-26T07:12:20.674Z]     dists = ws.resolve(reqs, Environment())
[2020-04-26T07:12:20.674Z]   File "/usr/lib/python2.7/site-packages/pkg_resources/__init__.py", line 787, in resolve
[2020-04-26T07:12:20.674Z]     raise DistributionNotFound(req, requirers)
[2020-04-26T07:12:20.674Z] pkg_resources.DistributionNotFound: The 'zipp>=0.5' distribution was not found and is required by importlib-metadata
[2020-04-26T07:12:20.674Z] ==> ERROR: A failure occurred in check().
[2020-04-26T07:12:20.674Z]     Aborting...
[2020-04-26T07:12:21.585Z] ==> ERROR: Build failed, check /build/buildpkg/default-x86_64/jenkins/build
[Pipeline] }
[Pipeline] // dir
Post stage
[Pipeline] emailext
[2020-04-26T07:12:21.676Z] Sending email to: artix-build-failures at artixlinux.org


More information about the artix-build-failures mailing list