[artix-build-failures] [galaxy-gremlins] Failure: python-http-parser

jenkins at artixlinux.org jenkins at artixlinux.org
Fri Apr 24 10:07:01 CEST 2020


   Failure

   Build: repos/community-testing-x86_64

   Packages:

   [python-http-parser-0.9.0-1-x86_64.pkg.tar.xz,
   python2-http-parser-0.9.0-1-x86_64.pkg.tar.xz]

   authorName: alium

   authorEmail: alium at artixlinux.org

   [1]https://orion.artixlinux.org/job/packagesPython/job/python-http-pars
   er/job/master/8/

References

   1. https://orion.artixlinux.org/job/packagesPython/job/python-http-parser/job/master/8/
-------------- next part --------------
Push event to branch master
Querying the current revision of branch master...
Current revision of branch master is dd6c4e243601b7af0ac2158883f7d91cc453a9ff
Obtained Jenkinsfile from dd6c4e243601b7af0ac2158883f7d91cc453a9ff
Running in Durability level: PERFORMANCE_OPTIMIZED
Loading library artix-ci at master
Attempting to resolve master from remote references...
 > git --version # timeout=10
 > git ls-remote -- https://gitea.artixlinux.org/artix/pipeline-libs.git # timeout=10
Found match: refs/heads/master revision 77f77ff85eedb6eb60b64faf8c328ab86dbb479c
Warning: CredentialId "gitea-ci" could not be found.
Cloning the remote Git repository
Cloning with configured refspecs honoured and without tags
Cloning repository https://gitea.artixlinux.org/artix/pipeline-libs.git
 > git init /build/jenkins/workspace/Python_python-http-parser_master at libs/artix-ci # timeout=10
Fetching upstream changes from https://gitea.artixlinux.org/artix/pipeline-libs.git
 > git --version # timeout=10
 > git fetch --no-tags --force --progress -- https://gitea.artixlinux.org/artix/pipeline-libs.git +refs/heads/master:refs/remotes/origin/master # timeout=10
 > git config remote.origin.url https://gitea.artixlinux.org/artix/pipeline-libs.git # timeout=10
 > git config --add remote.origin.fetch +refs/heads/master:refs/remotes/origin/master # timeout=10
 > git config remote.origin.url https://gitea.artixlinux.org/artix/pipeline-libs.git # timeout=10
Fetching without tags
Fetching upstream changes from https://gitea.artixlinux.org/artix/pipeline-libs.git
 > git fetch --no-tags --force --progress -- https://gitea.artixlinux.org/artix/pipeline-libs.git +refs/heads/master:refs/remotes/origin/master # timeout=10
Checking out Revision 77f77ff85eedb6eb60b64faf8c328ab86dbb479c (master)
 > git config core.sparsecheckout # timeout=10
 > git checkout -f 77f77ff85eedb6eb60b64faf8c328ab86dbb479c # timeout=10
Commit message: "Notify: remove fail condition"
[Gitea] Notifying branch build status: PENDING Build started...
[Gitea] Notified
[Pipeline] Start of Pipeline
[Pipeline] node
Still waiting to schedule task
Waiting for next available executor
Running on Jenkins in /build/jenkins/workspace/Python_python-http-parser_master
[Pipeline] {
[Pipeline] timestamps
[Pipeline] {
[Pipeline] stage
[Pipeline] { (Prepare)
[Pipeline] checkout
[2020-04-24T08:06:26.815Z] Warning: CredentialId "jenkins-ci" could not be found.
[2020-04-24T08:06:26.816Z] Cloning the remote Git repository
[2020-04-24T08:06:26.816Z] Cloning with configured refspecs honoured and without tags
[2020-04-24T08:06:26.816Z] Cloning repository https://237b7412742b4068af4173944de150f12959f4d3@gitea.artixlinux.org/packagesPython/python-http-parser.git
[2020-04-24T08:06:26.816Z]  > git init /build/jenkins/workspace/Python_python-http-parser_master # timeout=10
[2020-04-24T08:06:26.830Z] Fetching upstream changes from https://237b7412742b4068af4173944de150f12959f4d3@gitea.artixlinux.org/packagesPython/python-http-parser.git
[2020-04-24T08:06:26.830Z]  > git --version # timeout=10
[2020-04-24T08:06:26.834Z]  > git fetch --no-tags --force --progress -- https://237b7412742b4068af4173944de150f12959f4d3@gitea.artixlinux.org/packagesPython/python-http-parser.git +refs/heads/master:refs/remotes/origin/master # timeout=10
[2020-04-24T08:06:27.005Z]  > git config remote.origin.url https://237b7412742b4068af4173944de150f12959f4d3@gitea.artixlinux.org/packagesPython/python-http-parser.git # timeout=10
[2020-04-24T08:06:27.010Z]  > git config --add remote.origin.fetch +refs/heads/master:refs/remotes/origin/master # timeout=10
[2020-04-24T08:06:27.015Z]  > git config remote.origin.url https://237b7412742b4068af4173944de150f12959f4d3@gitea.artixlinux.org/packagesPython/python-http-parser.git # timeout=10
[2020-04-24T08:06:27.020Z] Cleaning workspace
[2020-04-24T08:06:27.020Z]  > git rev-parse --verify HEAD # timeout=10
[2020-04-24T08:06:27.025Z] No valid HEAD. Skipping the resetting
[2020-04-24T08:06:27.025Z]  > git clean -fdx # timeout=10
[2020-04-24T08:06:27.029Z] Fetching without tags
[2020-04-24T08:06:27.029Z] Fetching upstream changes from https://237b7412742b4068af4173944de150f12959f4d3@gitea.artixlinux.org/packagesPython/python-http-parser.git
[2020-04-24T08:06:27.029Z]  > git fetch --no-tags --force --progress -- https://237b7412742b4068af4173944de150f12959f4d3@gitea.artixlinux.org/packagesPython/python-http-parser.git +refs/heads/master:refs/remotes/origin/master # timeout=10
[2020-04-24T08:06:27.118Z] Checking out Revision dd6c4e243601b7af0ac2158883f7d91cc453a9ff (master)
[2020-04-24T08:06:27.118Z]  > git config core.sparsecheckout # timeout=10
[2020-04-24T08:06:27.123Z]  > git checkout -f dd6c4e243601b7af0ac2158883f7d91cc453a9ff # timeout=10
[2020-04-24T08:06:27.132Z] Commit message: "[trunk] -> [community-testing] 'python-http-parser-0.9.0-1' add"
[2020-04-24T08:06:27.133Z]  > git rev-list --no-walk 45a5a363d7deb6cf942a27575c6e3357fda80a80 # timeout=10
[2020-04-24T08:06:27.146Z] [Gitea] Notifying branch build status: PENDING Build started...
[2020-04-24T08:06:27.286Z] [Gitea] Notified
[Pipeline] libraryResource
[Pipeline] readYaml
[Pipeline] sh
[2020-04-24T08:06:27.559Z] + git rev-parse @
[Pipeline] sh
[2020-04-24T08:06:27.816Z] + git show -s --format=%an dd6c4e243601b7af0ac2158883f7d91cc453a9ff
[Pipeline] sh
[2020-04-24T08:06:28.073Z] + git show -s --format=%ae dd6c4e243601b7af0ac2158883f7d91cc453a9ff
[Pipeline] sh
[2020-04-24T08:06:28.330Z] + git show --pretty=format: --name-status dd6c4e243601b7af0ac2158883f7d91cc453a9ff
[Pipeline] fileExists
[Pipeline] sh
[2020-04-24T08:06:28.602Z] + pkg2yaml repos/community-testing-x86_64
[Pipeline] readYaml
[Pipeline] }
[Pipeline] // stage
[Pipeline] stage
[Pipeline] { (Build)
[Pipeline] echo
[2020-04-24T08:06:28.713Z] isRebuild: false
[Pipeline] dir
[2020-04-24T08:06:28.718Z] Running in /build/jenkins/workspace/Python_python-http-parser_master/repos/community-testing-x86_64
[Pipeline] {
[Pipeline] sh
[2020-04-24T08:06:28.980Z] + buildpkg-galaxy-gremlins
[2020-04-24T08:06:32.208Z] :: Synchronizing package databases...
[2020-04-24T08:06:32.208Z] downloading gremlins.db...
[2020-04-24T08:06:32.208Z]  system is up to date
[2020-04-24T08:06:32.208Z]  world is up to date
[2020-04-24T08:06:32.208Z]  galaxy-gremlins is up to date
[2020-04-24T08:06:32.208Z]  galaxy is up to date
[2020-04-24T08:06:32.208Z]  testing is up to date
[2020-04-24T08:06:32.208Z]  extra is up to date
[2020-04-24T08:06:32.208Z] downloading community-testing.db...
[2020-04-24T08:06:32.208Z] downloading community.db...
[2020-04-24T08:06:32.208Z] :: Starting full system upgrade...
[2020-04-24T08:06:32.208Z]  there is nothing to do
[2020-04-24T08:06:33.118Z] ==> Building in chroot for [gremlins] (x86_64)...
[2020-04-24T08:06:34.029Z] ==> Synchronizing chroot copy [/build/buildpkg/gremlins-x86_64/root] -> [jenkins]...done
[2020-04-24T08:06:35.890Z] ==> Making package: python-http-parser 0.9.0-1 (Fri Apr 24 10:06:35 2020)
[2020-04-24T08:06:35.890Z] ==> Retrieving sources...
[2020-04-24T08:06:35.890Z]   -> Downloading python-http-parser-0.9.0.tar.gz...
[2020-04-24T08:06:35.890Z]   % Total    % Received % Xferd  Average Speed   Time    Time     Time  Current
[2020-04-24T08:06:35.890Z]                                  Dload  Upload   Total   Spent    Left  Speed
[2020-04-24T08:06:35.890Z] 
  0     0    0     0    0     0      0      0 --:--:-- --:--:-- --:--:--     0
100   126  100   126    0     0    470      0 --:--:-- --:--:-- --:--:--   470
[2020-04-24T08:06:36.691Z] 
  0     0    0     0    0     0      0      0 --:--:-- --:--:-- --:--:--     0
100   98k    0   98k    0     0   106k      0 --:--:-- --:--:-- --:--:--  272k
[2020-04-24T08:06:36.691Z] ==> Validating source files with sha512sums...
[2020-04-24T08:06:36.691Z]     python-http-parser-0.9.0.tar.gz ... Passed
[2020-04-24T08:06:43.171Z] ==> Making package: python-http-parser 0.9.0-1 (Fri 24 Apr 2020 08:06:42 AM UTC)
[2020-04-24T08:06:43.171Z] ==> Checking runtime dependencies...
[2020-04-24T08:06:43.171Z] ==> Checking buildtime dependencies...
[2020-04-24T08:06:43.171Z] ==> Installing missing dependencies...
[2020-04-24T08:06:43.171Z] resolving dependencies...
[2020-04-24T08:06:43.171Z] looking for conflicting packages...
[2020-04-24T08:06:43.171Z] 
[2020-04-24T08:06:43.171Z] Package (46)                       New Version    Net Change  Download Size
[2020-04-24T08:06:43.171Z] 
[2020-04-24T08:06:43.171Z] system/libnsl                      1.2.0-2          0.19 MiB               
[2020-04-24T08:06:43.171Z] world/python                       3.8.2-2         80.70 MiB               
[2020-04-24T08:06:43.171Z] galaxy/python-apipkg               1.5-3            0.02 MiB               
[2020-04-24T08:06:43.171Z] world/python-appdirs               1.4.3-5          0.07 MiB               
[2020-04-24T08:06:43.171Z] galaxy/python-atomicwrites         1.3.0-3          0.03 MiB               
[2020-04-24T08:06:43.171Z] world/python-attrs                 19.3.0-4         0.30 MiB               
[2020-04-24T08:06:43.171Z] galaxy/python-importlib-metadata   1.5.1-1          0.18 MiB               
[2020-04-24T08:06:43.171Z] galaxy/python-iniconfig            1.0.0-4          0.02 MiB               
[2020-04-24T08:06:43.171Z] galaxy/python-more-itertools       8.2.0-1          0.25 MiB               
[2020-04-24T08:06:43.171Z] world/python-ordered-set           3.1.1-1          0.05 MiB               
[2020-04-24T08:06:43.171Z] world/python-packaging             20.3-1           0.17 MiB               
[2020-04-24T08:06:43.171Z] galaxy/python-pluggy               0.13.1-1         0.12 MiB               
[2020-04-24T08:06:43.171Z] galaxy/python-py                   1.8.1-1          0.70 MiB               
[2020-04-24T08:06:43.171Z] galaxy/python-pygments             2.6.1-2          9.42 MiB               
[2020-04-24T08:06:43.171Z] world/python-pyparsing             2.4.7-1          0.73 MiB               
[2020-04-24T08:06:43.171Z] world/python-six                   1.14.0-1         0.09 MiB               
[2020-04-24T08:06:43.171Z] galaxy/python-wcwidth              0.1.8-1          0.08 MiB               
[2020-04-24T08:06:43.171Z] galaxy/python-zipp                 3.1.0-1          0.03 MiB               
[2020-04-24T08:06:43.171Z] gremlins/python2                   2.7.18-1        75.39 MiB      11.83 MiB
[2020-04-24T08:06:43.171Z] community/python2-apipkg           1.5-3            0.03 MiB               
[2020-04-24T08:06:43.171Z] world/python2-appdirs              1.4.3-5          0.08 MiB               
[2020-04-24T08:06:43.171Z] community/python2-atomicwrites     1.3.0-3          0.03 MiB               
[2020-04-24T08:06:43.171Z] world/python2-attrs                19.3.0-4         0.33 MiB               
[2020-04-24T08:06:43.171Z] extra/python2-backports            1.0-2            0.00 MiB               
[2020-04-24T08:06:43.171Z] extra/python2-configparser         4.0.2-1          0.21 MiB               
[2020-04-24T08:06:43.171Z] galaxy/python2-contextlib2         0.6.0.post1-1    0.06 MiB               
[2020-04-24T08:06:43.171Z] community/python2-funcsigs         1.0.2-2          0.09 MiB               
[2020-04-24T08:06:43.171Z] galaxy/python2-importlib-metadata  1.5.1-1          0.20 MiB               
[2020-04-24T08:06:43.171Z] community/python2-iniconfig        1.0.0-4          0.02 MiB               
[2020-04-24T08:06:43.171Z] community/python2-more-itertools   5.0.0-1          0.48 MiB               
[2020-04-24T08:06:43.171Z] world/python2-ordered-set          3.1.1-1          0.05 MiB               
[2020-04-24T08:06:43.171Z] world/python2-packaging            20.3-1           0.19 MiB               
[2020-04-24T08:06:43.171Z] community/python2-pathlib2         2.3.5-1          0.18 MiB               
[2020-04-24T08:06:43.171Z] community/python2-pluggy           0.13.1-1         0.13 MiB               
[2020-04-24T08:06:43.171Z] galaxy/python2-py                  1.8.1-1          0.80 MiB               
[2020-04-24T08:06:43.171Z] world/python2-pyparsing            2.4.7-1          0.79 MiB               
[2020-04-24T08:06:43.171Z] community/python2-scandir          1.10.0-3         0.09 MiB               
[2020-04-24T08:06:43.171Z] world/python2-six                  1.14.0-1         0.10 MiB               
[2020-04-24T08:06:43.171Z] galaxy/python2-wcwidth             0.1.8-1          0.09 MiB               
[2020-04-24T08:06:43.171Z] galaxy/python2-zipp                2.0.0-1          0.02 MiB               
[2020-04-24T08:06:43.171Z] galaxy/cython                      0.29.16-1        8.54 MiB               
[2020-04-24T08:06:43.171Z] galaxy/cython2                     0.29.16-1        8.88 MiB               
[2020-04-24T08:06:43.171Z] galaxy/python-pytest               5.4.1-1          2.69 MiB               
[2020-04-24T08:06:43.171Z] world/python-setuptools            1:46.1.3-1       1.53 MiB               
[2020-04-24T08:06:43.171Z] community/python2-pytest           4.6.9-1          2.25 MiB               
[2020-04-24T08:06:43.171Z] world/python2-setuptools           1:45.0.0-1       1.75 MiB               
[2020-04-24T08:06:43.171Z] 
[2020-04-24T08:06:43.171Z] Total Download Size:    11.83 MiB
[2020-04-24T08:06:43.171Z] Total Installed Size:  198.16 MiB
[2020-04-24T08:06:43.171Z] 
[2020-04-24T08:06:43.171Z] :: Proceed with installation? [Y/n] 
[2020-04-24T08:06:43.171Z] :: Retrieving packages...
[2020-04-24T08:06:43.171Z] downloading python2-2.7.18-1-x86_64.pkg.tar.xz...
[2020-04-24T08:06:43.171Z] checking keyring...
[2020-04-24T08:06:43.171Z] checking package integrity...
[2020-04-24T08:06:45.654Z] loading package files...
[2020-04-24T08:06:45.904Z] checking for file conflicts...
[2020-04-24T08:06:45.904Z] checking available disk space...
[2020-04-24T08:06:45.904Z] :: Processing package changes...
[2020-04-24T08:06:45.904Z] installing libnsl...
[2020-04-24T08:06:45.904Z] installing python...
[2020-04-24T08:06:48.386Z] Optional dependencies for python
[2020-04-24T08:06:48.386Z]     python-setuptools [pending]
[2020-04-24T08:06:48.386Z]     python-pip
[2020-04-24T08:06:48.386Z]     sqlite [installed]
[2020-04-24T08:06:48.386Z]     mpdecimal: for decimal
[2020-04-24T08:06:48.386Z]     xz: for lzma [installed]
[2020-04-24T08:06:48.386Z]     tk: for tkinter
[2020-04-24T08:06:48.386Z] installing python-appdirs...
[2020-04-24T08:06:48.386Z] installing python-pyparsing...
[2020-04-24T08:06:48.386Z] installing python-six...
[2020-04-24T08:06:48.386Z] installing python-packaging...
[2020-04-24T08:06:48.386Z] installing python-ordered-set...
[2020-04-24T08:06:48.386Z] installing python-setuptools...
[2020-04-24T08:06:48.386Z] installing python2...
[2020-04-24T08:06:49.729Z] Optional dependencies for python2
[2020-04-24T08:06:49.729Z]     tk: for IDLE
[2020-04-24T08:06:49.729Z]     python2-setuptools [pending]
[2020-04-24T08:06:49.729Z]     python2-pip
[2020-04-24T08:06:49.730Z] installing python2-appdirs...
[2020-04-24T08:06:49.730Z] installing python2-pyparsing...
[2020-04-24T08:06:49.730Z] installing python2-six...
[2020-04-24T08:06:49.730Z] installing python2-packaging...
[2020-04-24T08:06:49.730Z] installing python2-ordered-set...
[2020-04-24T08:06:49.730Z] installing python2-setuptools...
[2020-04-24T08:06:49.730Z] installing cython...
[2020-04-24T08:06:49.730Z] installing cython2...
[2020-04-24T08:06:49.980Z] installing python-iniconfig...
[2020-04-24T08:06:49.980Z] installing python-apipkg...
[2020-04-24T08:06:49.980Z] installing python-py...
[2020-04-24T08:06:49.980Z] installing python-zipp...
[2020-04-24T08:06:49.980Z] installing python-importlib-metadata...
[2020-04-24T08:06:49.980Z] installing python-pluggy...
[2020-04-24T08:06:49.980Z] installing python-attrs...
[2020-04-24T08:06:49.980Z] installing python-more-itertools...
[2020-04-24T08:06:49.980Z] installing python-atomicwrites...
[2020-04-24T08:06:49.980Z] installing python-wcwidth...
[2020-04-24T08:06:49.980Z] installing python-pygments...
[2020-04-24T08:06:50.230Z] installing python-pytest...
[2020-04-24T08:06:50.230Z] installing python2-iniconfig...
[2020-04-24T08:06:50.230Z] installing python2-apipkg...
[2020-04-24T08:06:50.230Z] installing python2-py...
[2020-04-24T08:06:50.230Z] installing python2-more-itertools...
[2020-04-24T08:06:50.230Z] installing python2-zipp...
[2020-04-24T08:06:50.230Z] installing python2-backports...
[2020-04-24T08:06:50.230Z] installing python2-configparser...
[2020-04-24T08:06:50.230Z] installing python2-contextlib2...
[2020-04-24T08:06:50.230Z] installing python2-scandir...
[2020-04-24T08:06:50.230Z] installing python2-pathlib2...
[2020-04-24T08:06:50.230Z] installing python2-importlib-metadata...
[2020-04-24T08:06:50.230Z] installing python2-pluggy...
[2020-04-24T08:06:50.230Z] installing python2-attrs...
[2020-04-24T08:06:50.230Z] installing python2-atomicwrites...
[2020-04-24T08:06:50.230Z] installing python2-wcwidth...
[2020-04-24T08:06:50.230Z] installing python2-funcsigs...
[2020-04-24T08:06:50.230Z] installing python2-pytest...
[2020-04-24T08:06:50.481Z] ==> Retrieving sources...
[2020-04-24T08:06:50.481Z]   -> Found python-http-parser-0.9.0.tar.gz
[2020-04-24T08:06:50.481Z] ==> WARNING: Skipping all source file integrity checks.
[2020-04-24T08:06:50.481Z] ==> Extracting sources...
[2020-04-24T08:06:50.481Z]   -> Extracting python-http-parser-0.9.0.tar.gz with bsdtar
[2020-04-24T08:06:50.481Z] ==> Starting prepare()...
[2020-04-24T08:06:50.481Z] ==> Starting build()...
[2020-04-24T08:06:50.738Z] running build
[2020-04-24T08:06:50.738Z] running build_py
[2020-04-24T08:06:50.738Z] creating build
[2020-04-24T08:06:50.738Z] creating build/lib.linux-x86_64-3.8
[2020-04-24T08:06:50.738Z] creating build/lib.linux-x86_64-3.8/http_parser
[2020-04-24T08:06:50.738Z] copying http_parser/util.py -> build/lib.linux-x86_64-3.8/http_parser
[2020-04-24T08:06:50.738Z] copying http_parser/reader.py -> build/lib.linux-x86_64-3.8/http_parser
[2020-04-24T08:06:50.738Z] copying http_parser/pyparser.py -> build/lib.linux-x86_64-3.8/http_parser
[2020-04-24T08:06:50.738Z] copying http_parser/http.py -> build/lib.linux-x86_64-3.8/http_parser
[2020-04-24T08:06:50.738Z] copying http_parser/_socketio.py -> build/lib.linux-x86_64-3.8/http_parser
[2020-04-24T08:06:50.738Z] copying http_parser/__init__.py -> build/lib.linux-x86_64-3.8/http_parser
[2020-04-24T08:06:50.738Z] running build_ext
[2020-04-24T08:06:50.738Z] cython -o http_parser.parser.c http_parser/parser.pyx
[2020-04-24T08:06:51.649Z] /usr/lib/python3.8/site-packages/Cython/Compiler/Main.py:369: FutureWarning: Cython directive 'language_level' not set, using 2 for now (Py2). This will change in a later release! File: /build/python-http-parser/src/http-parser-0.9.0/http_parser/parser.pyx
[2020-04-24T08:06:51.649Z]   tree = Parsing.p_module(s, pxd, full_module_name)
[2020-04-24T08:06:51.649Z] warning: http_parser/parser.pyx:231:32: Casting a GIL-requiring function into a nogil function circumvents GIL validation
[2020-04-24T08:06:51.649Z] warning: http_parser/parser.pyx:232:33: Casting a GIL-requiring function into a nogil function circumvents GIL validation
[2020-04-24T08:06:51.649Z] warning: http_parser/parser.pyx:233:41: Casting a GIL-requiring function into a nogil function circumvents GIL validation
[2020-04-24T08:06:51.649Z] warning: http_parser/parser.pyx:234:41: Casting a GIL-requiring function into a nogil function circumvents GIL validation
[2020-04-24T08:06:51.649Z] warning: http_parser/parser.pyx:235:45: Casting a GIL-requiring function into a nogil function circumvents GIL validation
[2020-04-24T08:06:51.649Z] warning: http_parser/parser.pyx:236:42: Casting a GIL-requiring function into a nogil function circumvents GIL validation
[2020-04-24T08:06:51.649Z] warning: http_parser/parser.pyx:237:45: Casting a GIL-requiring function into a nogil function circumvents GIL validation
[2020-04-24T08:06:51.649Z] mv http_parser.parser.c http_parser/parser.c
[2020-04-24T08:06:51.649Z] building 'http_parser.parser' extension
[2020-04-24T08:06:51.649Z] creating build/temp.linux-x86_64-3.8
[2020-04-24T08:06:51.649Z] creating build/temp.linux-x86_64-3.8/http_parser
[2020-04-24T08:06:51.649Z] gcc -pthread -Wno-unused-result -Wsign-compare -DNDEBUG -g -fwrapv -O3 -Wall -march=x86-64 -mtune=generic -O3 -pipe -fno-plt -fno-semantic-interposition -march=x86-64 -mtune=generic -O3 -pipe -fno-plt -march=x86-64 -mtune=generic -O3 -pipe -fno-plt -march=x86-64 -mtune=generic -O2 -pipe -fno-plt -D_FORTIFY_SOURCE=2 -fPIC -Iparser -I/usr/include/python3.8 -c http_parser/http_parser.c -o build/temp.linux-x86_64-3.8/http_parser/http_parser.o
[2020-04-24T08:06:52.199Z] gcc -pthread -Wno-unused-result -Wsign-compare -DNDEBUG -g -fwrapv -O3 -Wall -march=x86-64 -mtune=generic -O3 -pipe -fno-plt -fno-semantic-interposition -march=x86-64 -mtune=generic -O3 -pipe -fno-plt -march=x86-64 -mtune=generic -O3 -pipe -fno-plt -march=x86-64 -mtune=generic -O2 -pipe -fno-plt -D_FORTIFY_SOURCE=2 -fPIC -Iparser -I/usr/include/python3.8 -c http_parser/parser.c -o build/temp.linux-x86_64-3.8/http_parser/parser.o
[2020-04-24T08:06:53.542Z] http_parser/parser.c: In function ‘__pyx_pw_11http_parser_6parser_10HttpParser_1__init__’:
[2020-04-24T08:06:53.542Z] http_parser/parser.c:3800:3: warning: ‘__pyx_v_parser_type’ may be used uninitialized in this function [-Wmaybe-uninitialized]
[2020-04-24T08:06:53.542Z]  3800 |   http_parser_init((&__pyx_v_self->_parser), __pyx_v_parser_type);
[2020-04-24T08:06:53.542Z]       |   ^~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~
[2020-04-24T08:06:53.542Z] http_parser/parser.c:3688:25: note: ‘__pyx_v_parser_type’ was declared here
[2020-04-24T08:06:53.542Z]  3688 |   enum http_parser_type __pyx_v_parser_type;
[2020-04-24T08:06:53.542Z]       |                         ^~~~~~~~~~~~~~~~~~~
[2020-04-24T08:06:56.025Z] gcc -pthread -shared -Wl,-O1,--sort-common,--as-needed,-z,relro,-z,now -fno-semantic-interposition -Wl,-O1,--sort-common,--as-needed,-z,relro,-z,now -Wl,-O1,--sort-common,--as-needed,-z,relro,-z,now -march=x86-64 -mtune=generic -O2 -pipe -fno-plt -D_FORTIFY_SOURCE=2 build/temp.linux-x86_64-3.8/http_parser/http_parser.o build/temp.linux-x86_64-3.8/http_parser/parser.o -L/usr/lib -o build/lib.linux-x86_64-3.8/http_parser/parser.cpython-38-x86_64-linux-gnu.so
[2020-04-24T08:06:56.025Z] setup.py:12: DeprecationWarning: the imp module is deprecated in favour of importlib; see the module's documentation for alternative uses
[2020-04-24T08:06:56.025Z]   from imp import load_source
[2020-04-24T08:06:56.025Z] Linking /build/python-http-parser/src/http-parser-0.9.0/build/lib.linux-x86_64-3.8/http_parser/parser.cpython-38-x86_64-linux-gnu.so to /build/python-http-parser/src/http-parser-0.9.0/http_parser/parser.cpython-38-x86_64-linux-gnu.so
[2020-04-24T08:06:56.025Z] /usr/lib/python2.7/site-packages/pkg_resources/py2_warn.py:19: UserWarning: ************************************************************
[2020-04-24T08:06:56.025Z] You are running Setuptools on Python 2, which is no longer
[2020-04-24T08:06:56.025Z] supported and
[2020-04-24T08:06:56.025Z] >>> SETUPTOOLS WILL STOP WORKING <<<
[2020-04-24T08:06:56.025Z] in a subsequent release. Please ensure you are installing
[2020-04-24T08:06:56.025Z] Setuptools using pip 9.x or later or pin to `setuptools<45`
[2020-04-24T08:06:56.025Z] in your environment.
[2020-04-24T08:06:56.025Z] If you have done those things and are still encountering
[2020-04-24T08:06:56.025Z] this message, please comment in
[2020-04-24T08:06:56.025Z] https://github.com/pypa/setuptools/issues/1458
[2020-04-24T08:06:56.025Z] about the steps that led to this unsupported combination.
[2020-04-24T08:06:56.025Z] ************************************************************
[2020-04-24T08:06:56.025Z]   sys.version_info < (3,) and warnings.warn("*" * 60 + msg + "*" * 60)
[2020-04-24T08:06:56.025Z] running build
[2020-04-24T08:06:56.025Z] running build_py
[2020-04-24T08:06:56.025Z] creating build
[2020-04-24T08:06:56.025Z] creating build/lib.linux-x86_64-2.7
[2020-04-24T08:06:56.025Z] creating build/lib.linux-x86_64-2.7/http_parser
[2020-04-24T08:06:56.025Z] copying http_parser/util.py -> build/lib.linux-x86_64-2.7/http_parser
[2020-04-24T08:06:56.025Z] copying http_parser/reader.py -> build/lib.linux-x86_64-2.7/http_parser
[2020-04-24T08:06:56.025Z] copying http_parser/pyparser.py -> build/lib.linux-x86_64-2.7/http_parser
[2020-04-24T08:06:56.025Z] copying http_parser/http.py -> build/lib.linux-x86_64-2.7/http_parser
[2020-04-24T08:06:56.025Z] copying http_parser/_socketio.py -> build/lib.linux-x86_64-2.7/http_parser
[2020-04-24T08:06:56.025Z] copying http_parser/__init__.py -> build/lib.linux-x86_64-2.7/http_parser
[2020-04-24T08:06:56.025Z] running build_ext
[2020-04-24T08:06:56.025Z] cython -o http_parser.parser.c http_parser/parser.pyx
[2020-04-24T08:06:56.935Z] /usr/lib/python3.8/site-packages/Cython/Compiler/Main.py:369: FutureWarning: Cython directive 'language_level' not set, using 2 for now (Py2). This will change in a later release! File: /build/python-http-parser/src/http-parser-0.9.0-py2/http_parser/parser.pyx
[2020-04-24T08:06:56.935Z]   tree = Parsing.p_module(s, pxd, full_module_name)
[2020-04-24T08:06:56.935Z] warning: http_parser/parser.pyx:231:32: Casting a GIL-requiring function into a nogil function circumvents GIL validation
[2020-04-24T08:06:56.935Z] warning: http_parser/parser.pyx:232:33: Casting a GIL-requiring function into a nogil function circumvents GIL validation
[2020-04-24T08:06:56.935Z] warning: http_parser/parser.pyx:233:41: Casting a GIL-requiring function into a nogil function circumvents GIL validation
[2020-04-24T08:06:56.935Z] warning: http_parser/parser.pyx:234:41: Casting a GIL-requiring function into a nogil function circumvents GIL validation
[2020-04-24T08:06:56.936Z] warning: http_parser/parser.pyx:235:45: Casting a GIL-requiring function into a nogil function circumvents GIL validation
[2020-04-24T08:06:56.936Z] warning: http_parser/parser.pyx:236:42: Casting a GIL-requiring function into a nogil function circumvents GIL validation
[2020-04-24T08:06:56.936Z] warning: http_parser/parser.pyx:237:45: Casting a GIL-requiring function into a nogil function circumvents GIL validation
[2020-04-24T08:06:56.936Z] mv http_parser.parser.c http_parser/parser.c
[2020-04-24T08:06:56.936Z] building 'http_parser.parser' extension
[2020-04-24T08:06:56.936Z] creating build/temp.linux-x86_64-2.7
[2020-04-24T08:06:56.936Z] creating build/temp.linux-x86_64-2.7/http_parser
[2020-04-24T08:06:56.936Z] gcc -pthread -fno-strict-aliasing -march=x86-64 -mtune=generic -O2 -pipe -fno-plt -DNDEBUG -march=x86-64 -mtune=generic -O2 -pipe -fno-plt -march=x86-64 -mtune=generic -O2 -pipe -fno-plt -D_FORTIFY_SOURCE=2 -fPIC -Iparser -I/usr/include/python2.7 -c http_parser/http_parser.c -o build/temp.linux-x86_64-2.7/http_parser/http_parser.o
[2020-04-24T08:06:57.486Z] gcc -pthread -fno-strict-aliasing -march=x86-64 -mtune=generic -O2 -pipe -fno-plt -DNDEBUG -march=x86-64 -mtune=generic -O2 -pipe -fno-plt -march=x86-64 -mtune=generic -O2 -pipe -fno-plt -D_FORTIFY_SOURCE=2 -fPIC -Iparser -I/usr/include/python2.7 -c http_parser/parser.c -o build/temp.linux-x86_64-2.7/http_parser/parser.o
[2020-04-24T08:07:00.713Z] gcc -pthread -shared -Wl,-O1,--sort-common,--as-needed,-z,relro,-z,now -Wl,-O1,--sort-common,--as-needed,-z,relro,-z,now -march=x86-64 -mtune=generic -O2 -pipe -fno-plt -D_FORTIFY_SOURCE=2 build/temp.linux-x86_64-2.7/http_parser/http_parser.o build/temp.linux-x86_64-2.7/http_parser/parser.o -L/usr/lib -lpython2.7 -o build/lib.linux-x86_64-2.7/http_parser/parser.so
[2020-04-24T08:07:00.713Z] Linking /build/python-http-parser/src/http-parser-0.9.0-py2/build/lib.linux-x86_64-2.7/http_parser/parser.so to /build/python-http-parser/src/http-parser-0.9.0-py2/http_parser/parser.so
[2020-04-24T08:07:00.713Z] ==> Starting check()...
[2020-04-24T08:07:00.713Z] ============================= test session starts ==============================
[2020-04-24T08:07:00.713Z] platform linux -- Python 3.8.2, pytest-5.4.1, py-1.8.1, pluggy-0.13.1
[2020-04-24T08:07:00.713Z] rootdir: /build/python-http-parser/src/http-parser-0.9.0
[2020-04-24T08:07:00.713Z] collected 12 items
[2020-04-24T08:07:00.713Z] 
[2020-04-24T08:07:00.714Z] testing/test_headers.py .......                                          [ 58%]
[2020-04-24T08:07:00.714Z] testing/test_parse_from_stream.py ....                                   [ 91%]
[2020-04-24T08:07:00.714Z] testing/test_response.py .                                               [100%]
[2020-04-24T08:07:00.714Z] 
[2020-04-24T08:07:00.714Z] =============================== warnings summary ===============================
[2020-04-24T08:07:00.714Z] build/lib.linux-x86_64-3.8/http_parser/pyparser.py:22
[2020-04-24T08:07:00.714Z]   /build/python-http-parser/src/http-parser-0.9.0/build/lib.linux-x86_64-3.8/http_parser/pyparser.py:22: DeprecationWarning: invalid escape sequence \d
[2020-04-24T08:07:00.714Z]     VERSION_RE = re.compile("HTTP/(\d+).(\d+)")
[2020-04-24T08:07:00.714Z] 
[2020-04-24T08:07:00.714Z] build/lib.linux-x86_64-3.8/http_parser/pyparser.py:23
[2020-04-24T08:07:00.714Z]   /build/python-http-parser/src/http-parser-0.9.0/build/lib.linux-x86_64-3.8/http_parser/pyparser.py:23: DeprecationWarning: invalid escape sequence \d
[2020-04-24T08:07:00.714Z]     STATUS_RE = re.compile("(\d{3})\s*(\w*)")
[2020-04-24T08:07:00.714Z] 
[2020-04-24T08:07:00.714Z] build/lib.linux-x86_64-3.8/http_parser/pyparser.py:24
[2020-04-24T08:07:00.714Z]   /build/python-http-parser/src/http-parser-0.9.0/build/lib.linux-x86_64-3.8/http_parser/pyparser.py:24: DeprecationWarning: invalid escape sequence \[
[2020-04-24T08:07:00.714Z]     HEADER_RE = re.compile("[\x00-\x1F\x7F()<>@,;:\[\]={} \t\\\\\"]")
[2020-04-24T08:07:00.714Z] 
[2020-04-24T08:07:00.714Z] -- Docs: https://docs.pytest.org/en/latest/warnings.html
[2020-04-24T08:07:00.714Z] ======================== 12 passed, 3 warnings in 0.07s ========================
[2020-04-24T08:07:00.714Z] /usr/lib/python2.7/site-packages/pkg_resources/py2_warn.py:19: UserWarning: ************************************************************
[2020-04-24T08:07:00.714Z] You are running Setuptools on Python 2, which is no longer
[2020-04-24T08:07:00.714Z] supported and
[2020-04-24T08:07:00.714Z] >>> SETUPTOOLS WILL STOP WORKING <<<
[2020-04-24T08:07:00.714Z] in a subsequent release. Please ensure you are installing
[2020-04-24T08:07:00.714Z] Setuptools using pip 9.x or later or pin to `setuptools<45`
[2020-04-24T08:07:00.714Z] in your environment.
[2020-04-24T08:07:00.714Z] If you have done those things and are still encountering
[2020-04-24T08:07:00.714Z] this message, please comment in
[2020-04-24T08:07:00.714Z] https://github.com/pypa/setuptools/issues/1458
[2020-04-24T08:07:00.714Z] about the steps that led to this unsupported combination.
[2020-04-24T08:07:00.714Z] ************************************************************
[2020-04-24T08:07:00.714Z]   sys.version_info < (3,) and warnings.warn("*" * 60 + msg + "*" * 60)
[2020-04-24T08:07:00.964Z] Traceback (most recent call last):
[2020-04-24T08:07:00.964Z]   File "/usr/bin/py.test2", line 6, in <module>
[2020-04-24T08:07:00.964Z]     from pkg_resources import load_entry_point
[2020-04-24T08:07:00.964Z]   File "/usr/lib/python2.7/site-packages/pkg_resources/__init__.py", line 3252, in <module>
[2020-04-24T08:07:00.964Z]     @_call_aside
[2020-04-24T08:07:00.964Z]   File "/usr/lib/python2.7/site-packages/pkg_resources/__init__.py", line 3236, in _call_aside
[2020-04-24T08:07:00.964Z]     f(*args, **kwargs)
[2020-04-24T08:07:00.964Z]   File "/usr/lib/python2.7/site-packages/pkg_resources/__init__.py", line 3265, in _initialize_master_working_set
[2020-04-24T08:07:00.964Z]     working_set = WorkingSet._build_master()
[2020-04-24T08:07:00.964Z]   File "/usr/lib/python2.7/site-packages/pkg_resources/__init__.py", line 586, in _build_master
[2020-04-24T08:07:00.964Z]     return cls._build_from_requirements(__requires__)
[2020-04-24T08:07:00.964Z]   File "/usr/lib/python2.7/site-packages/pkg_resources/__init__.py", line 599, in _build_from_requirements
[2020-04-24T08:07:00.964Z]     dists = ws.resolve(reqs, Environment())
[2020-04-24T08:07:00.964Z]   File "/usr/lib/python2.7/site-packages/pkg_resources/__init__.py", line 787, in resolve
[2020-04-24T08:07:00.964Z]     raise DistributionNotFound(req, requirers)
[2020-04-24T08:07:00.964Z] pkg_resources.DistributionNotFound: The 'zipp>=0.5' distribution was not found and is required by importlib-metadata
[2020-04-24T08:07:00.964Z] ==> ERROR: A failure occurred in check().
[2020-04-24T08:07:00.964Z]     Aborting...
[2020-04-24T08:07:01.875Z] ==> ERROR: Build failed, check /build/buildpkg/gremlins-x86_64/jenkins/build
[Pipeline] }
[Pipeline] // dir
Post stage
[Pipeline] emailext
[2020-04-24T08:07:01.936Z] Sending email to: artix-build-failures at artixlinux.org


More information about the artix-build-failures mailing list